Linux repositories inspector
13 febbraio 2020
APT 2.0.1

apt

Command-line package manager for Debian packages

NOME

apt - interfaccia a riga di comando

SINOSSI

apt [-h] [-o=stringa_config] [-c=file_config] [-t=rilascio_obiettivo] [-a=architettura] {list | search | show | update | install pacch [{=numero_versione_pacch | /rilascio_obiettivo}]... | remove pacch... | upgrade | full-upgrade | edit-sources | {-v | --version} | {-h | --help}}

DESCRIZIONE

apt fornisce uninterfaccia a riga di comando di alto livello per il sistema di gestione dei pacchetti. \(‘E pensata come interfaccia per lutente finale e permette in modo predefinito alcune opzioni pi\(‘u adatte per luso interattivo rispetto a strumenti APT pi\(‘u specializzati come apt-get(8) e apt-cache(8).
Proprio come apt stesso, la sua pagina di manuale \(‘e pensata come interfaccia per lutente finale e, pertanto, menziona solamente i comandi e le opzioni pi\(‘u utilizzati, in parte per non duplicare le informazioni in pi\(‘u posti e in parte per evitare di travolgere i lettori con una valanga di opzioni e dettagli.
update (apt-get(8))
update viene usato per scaricare le informazioni sui pacchetti da tutte le fonti configurate. Altri comandi operano su questi dati, ad esempio per effettuare gli aggiornamenti dei pacchetti o per cercare e visualizzare i dettagli su tutti i pacchetti disponibili per linstallazione.
upgrade (apt-get(8))
upgrade viene usato per installare gli aggiornamenti disponibili per tutti i pacchetti attualmente installati nel sistema prendendoli dalle fonti configurate attraverso sources.list(5). Nuovi pacchetti verranno installati se necessari per soddisfare le dipendenze, ma quelli esistenti non saranno mai rimossi. Se laggiornamento di un pacchetto richiede la rimozione di un pacchetto installato, laggiornamento di tale pacchetto non viene effettuato.
full-upgrade (apt-get(8))
full-upgrade effettua la funzione di aggiornamento ma rimuove i pacchetti attualmente installati se ci\(‘o \(‘e necessario per aggiornare il sistema nel suo complesso.
install, reinstall, remove, purge (apt-get(8))
Effettua lazione richiesta su uno o pi\(‘u pacchetti specificati attraverso regex(7), glob(7) o una corrispondenza esatta. Lazione richiesta pu\(‘o essere modificata per pacchetti specifici aggiungendo un segno pi\(‘u (+) al nome di un pacchetto per installarlo o un segno meno (-) per rimuoverlo.
\(‘E possibile selezionare una versione specifica di un pacchetto per linstallazione scrivendo dopo il nome del pacchetto un segno di uguale (=) e la versione del pacchetto da selezionare. In alternativa pu\(‘o essere selezionata la versione da un rilascio specifico scrivendo dopo il nome del pacchetto una sbarra (\(Fo/\(Fc) e il nome in codice (buster, bullseye, sid ...) o il nome della suite (stable, testing, unstable). Se necessarie per soddisfare la richiesta, anche le dipendenze del pacchetto in oggetto saranno selezionate da questo rilascio.
La rimozione di un pacchetto rimuove tutti i dati pacchettizzati, ma solitamente lascia piccoli file di configurazione utente (modificati), nel caso la rimozione sia avvenuta per errore. In questo caso basta una richiesta di installazione del pacchetto rimosso per sbaglio per ripristinare il suo funzionamento come era prima. Daltro canto ci si pu\(‘o sbarazzare di questi avanzi di file chiamando purge anche sui pacchetti gi\(‘a rimossi. Notare che ci\(‘o non ha effetto sui dati o le configurazioni memorizzate nelle directory personali degli utenti.
autoremove (apt-get(8))
autoremove viene usato per rimuovere i pacchetti che sono stati installati automaticamente per soddisfare delle dipendenze per altri pacchetti e che non sono pi\(‘u necessari perch\(’e le dipendenze sono cambiate o perch\(’e i pacchetti che li richiedevano sono stati nel frattempo rimossi.
Si dovrebbe controllare che la lelenco non includa applicazioni che sono nel frattempo diventate desiderate, anche se sono state inizialmente installate solo come dipendenze di un altro pacchetto. Si possono marcare tali pacchetti come installati manualmente usando apt-mark(8). Anche i pacchetti che sono stati esplicitamente installati con install non vengono mai proposti per la rimozione automatica.
satisfy (apt-get(8))
satisfy satisfies dependency strings, as used in Build-Depends. It also handles conflicts, by prefixing an argument with "Conflicts: ".
Example: apt satisfy "foo, bar (>= 1.0)" "Conflicts: baz, fuzz"
search (apt-cache(8))
search pu\(‘o essere usato per cercare daterminati termini regex(7) nellelenco dei pacchetti disponibili e per visualizzare le corrispondenze. Ci\(‘o \(‘e ad esempio utile se si stanno cercando pacchetti con una specifica funzionalit\(‘a. Per cercare un pacchetto che contiene un file specifico provare apt-file(1).
Mostra informazioni sui pacchetti specificati, incluse le loro dipendenze, le dimensioni di installazione e scaricamento, le fonti da cui sono disponibili, le descrizioni del contenuto dei pacchetti e molto altro. Pu\(‘o ad esempio essere utile per vedere tutte queste informazioni prima di permettere ad apt(8) di rimuovere un pacchetto o quando si cercano nuovi pacchetti da installare.
list
list \(‘e in qualche modo simile a dpkg-query --list, nel senso che pu\(‘o visualizzare un elenco di pacchetti che soddisfano determinati criteri. Supporta luso di modelli glob(7) per le corrispondenze con i nomi dei pacchetti, cos\(‘i come opzioni per elencare le versioni installate (--installed), aggiornabili (--upgradeable) o disponibili (--all-versions).
edit-sources (lavoro-in-corso)
edit-sources permette di modificare i propri file sources.list(5) nelleditor di testo preferito e fornisce controlli di sanit\(‘a di base.

USO DI SCRIPT E DIFFERENZE RISPETTO AD ALTRI STRUMENTI APT

La riga di comando di apt(8) \(‘e progettata come strumento per lutente finale e il suo comportamento pu\(‘o cambiare da una versione ad unaltra. Sebbene si cerchi di non rompere la compatibilit\(‘a allindietro, questa per\(‘o non \(‘e garantita se una modifica sembra utile per luso interattivo.
Tutte le funzionalit\(‘a di apt(8) sono anche disponibili in strumenti APT dedicati come apt-get(8) e apt-cache(8). apt(8) cambia solamente il valore predefinito di alcune opzioni (vedere apt.conf(5) e in particolare la sezione Binary). Perci\(‘o si raccomanda di preferire luso di questi comandi (potenzialmente con abilitate alcune opzioni aggiuntive) negli script, dato che essi mantengono il pi\(‘u possibile la compatibilit\(‘a allindietro.

VEDERE ANCHE

apt-get(8), apt-cache(8), sources.list(5), apt.conf(5), apt-config(8), la Guida dellutente di APT in /usr/share/doc/apt-doc/, apt_preferences(5), lAPT Howto.

DIAGNOSTICA

apt restituisce zero in caso di funzionamento normale e il valore decimale 100 in caso di errore.

BUG

\m[blue]Pagina dei bug di APT\m[][1]. Se si desidera segnalare un bug in APT, vedere /usr/share/doc/debian/bug-reporting.txt o il comando reportbug(1).

TRADUZIONE

Traduzione in italiano a cura del Team italiano di localizzazione di Debian <>. In particolare hanno contribuito Eugenia Franzoni (2000), Hugh Hartmann (2000-2012), Gabriele Stilli (2012), Beatrice Torracca (2012, 2014, 2015).
Notare che questa versione tradotta del documento pu\(&#145;o contenere parti non tradotte. Ci\(&#145;o \(&#145;e voluto, per evitare di perdere contenuti quando la traduzione non \(&#145;e aggiornata rispetto alloriginale.

AUTORE

Team APT

NOTE

1. Pagina dei bug di APT http://bugs.debian.org/src:apt
⇧ Top