Linux repositories inspector

2to3 - 2to3 binary using python3

Python, the high-level, interactive object oriented language, includes an extensive class library with lots of goodies for network programming, system administration, sounds and graphics.
This package is a dependency package, which depends on Debian's default Python 3 2to3 version (currently v3.6).
Original maintainer
Homepagehttps://www.python.org/
3.7.3
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
Ubuntu iconUbuntu 19.10
3.6.7
Ubuntu iconUbuntu 18.04 LTS
Ubuntu iconUbuntu 18.10
3.6.6
Ubuntu iconUbuntu 18.10
3.6.5
Ubuntu iconUbuntu 18.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb3.7.3-1Jun 1720.4 kiB42 kiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb3.6.5-32018-06-197.89 kiB42 kiB
Ubuntu iconUbuntu 18.04 LTS bionic-updates/universedeb3.6.7-1~18.04Jan 127.86 kiB42 kiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb3.6.6-1Jan 147.76 kiB42 kiB
Ubuntu iconUbuntu 18.10 cosmic-updates/universedeb3.6.7-1~18.10Jan 147.79 kiB42 kiB
Ubuntu iconUbuntu 19.04 disco/universedeb3.7.3-1Apr 037.59 kiB42 kiB
Ubuntu iconUbuntu 19.10 eoan/universedeb3.7.3-1Jun 177.59 kiB42 kiB

Manual pages

2to3(1)

2to3-3.3 - Python2 to Python3 converter

Latest updates

Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 3.7.3-1 reintroduced

Jun 20
  • Bump version to 3.7.3.
Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 3.7.3-1 removed

Jun 20
Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 3.7.3-1 introduced

Jun 17
  • Bump version to 3.7.3.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 3.7.2-1 to 3.7.3-1

Jun 17
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Updated from 3.7.2-1 to 3.7.3-1

Apr 03
  • Bump version to 3.7.3.
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 3.7.3-1 removed

Apr 03
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 3.7.3-1 introduced

Mar 26
  • Bump version to 3.7.3.
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 3.7.2-1 removed

Jan 30
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Updated from 3.7.1-1ubuntu1 to 3.7.2-1

Jan 30
  • Bump version to 3.7.2.
  • Bump standards version.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 3.7.1-3 to 3.7.2-1

Jan 27
  • Bump version to 3.7.2.
  • Bump standards version.
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 3.7.2-1 introduced

Jan 18
  • Bump version to 3.7.2.
  • Bump standards version.
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Version 3.7.1-1ubuntu1 introduced

Jan 14
  • Remove python3.6 as a supported Python3 version.
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-updates/universe: Version 3.6.7-1~18.10 introduced

Jan 14
  • SRU: LP: #1799206.
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic/universe: Version 3.6.6-1 introduced

Jan 14
Matthias Klose
  • Fix the idle desktop file. Closes: #901096.
  • Install the policy files in the python3 package. Closes: #901486.
  • python3-minimal: Pre-Depend on python3.6-minimal. Closes: #901001.
  • Bump version to 3.6.6.
Scott Kitterman
  • Remove myself from uploaders
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 3.6.4-1 to 3.7.1-3

Jan 12
  • Remove 3.6 as a supported Python3 versions.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-updates/universe: Version 3.6.7-1~18.04 introduced

Jan 12
  • SRU: LP: #1799206.
  • Drop python3.7 as a supported python3 version for the bionic SRU.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 3.6.4-1 to 3.6.5-3

2018-06-19
  • Update valgrind support file. LP: #1513364.
  • debian/control.in (Michael Vogt):
    • add Cnf-Visible-Pkgname hint to ensure command-not-found recommends installing "python3" instead of "python3-minimal" when it is missing.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 3.6.4-1 removed

2018-02-26
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Version 3.6.4-1 introduced

2018-02-26
  • Bump version to 3.6.4.
  • 2to3: Depend on python3-2to3 and provide the 2to3 launcher.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 3.6.4~rc1-2 to 3.6.4-1

2018-01-03
  • Bump version to 3.6.4.
  • 2to3: Depend on python3-2to3 and provide the 2to3 launcher.
⇧ Top