Linux repositories inspector

agda-mode - dependently typed functional programming language — emacs mode

Agda is a dependently typed functional programming language: It has inductive families, which are like Haskell's GADTs, but they can be indexed by values and not just types. It also has parameterised modules, mixfix operators, Unicode characters, and an interactive Emacs interface (the type checker can assist in the development of your code).
Agda is also a proof assistant: It is an interactive system for writing and checking proofs. Agda is based on intuitionistic type theory, a foundational system for constructive mathematics developed by the Swedish logician Per Martin-Löf. It has many similarities with other proof assistants based on dependent types, such as Coq, Epigram and NuPRL.
This package contains the emacs interactive development mode for Agda. This mode is the preferred way to write Agda code, and offers features such as iterative development, refinement, case analysis and so on.
2.6.0.1
Ubuntu iconUbuntu 19.10
Ubuntu iconUbuntu 20.04
2.5.4.1
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
2.5.3
Ubuntu iconUbuntu 18.04 LTS
Ubuntu iconUbuntu 18.10
2.5.2
Ubuntu iconUbuntu 17.10
2.5.1.1
Debian iconDebian 9.0
2.4.2.5
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb2.5.4.1-32019-01-12115 kiB122 kiB
Debian iconDebian 9.0 stretch/maindeb2.5.1.1-32017-11-1077.8 kiB85 kiB
Ubuntu iconUbuntu 17.10 artful/universedeb2.5.2-2build12017-11-104.01 kiB22 kiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb2.5.3-3build12017-11-273.5 kiB23 kiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb2.5.3-5build32019-01-143.49 kiB23 kiB
Ubuntu iconUbuntu 19.04 disco/universedeb2.5.4.1-32019-01-143.61 kiB22 kiB
Ubuntu iconUbuntu 19.10 eoan/universedeb2.6.0.1-1build22019-09-093.58 kiB23 kiB
Ubuntu iconUbuntu 20.04 focal/universedeb2.6.0.1-1build42020-02-083.56 kiB23 kiB
Ubuntu iconUbuntu 16.04 LTS xenial/universedeb2.4.2.5-1build12017-11-1036.4 kiB221 kiB

Latest updates

Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 2.6.0.1-1build3 to 2.6.0.1-1build4

2020-02-08
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 2.6.0.1-1build4 removed

2020-02-08
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 2.6.0.1-1build4 introduced

2020-02-08
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 2.6.0.1-1build2 to 2.6.0.1-1build3

2020-01-31
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 2.6.0.1-1build3 removed

2020-01-31
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 2.6.0.1-1build3 introduced

2020-01-13
Ubuntu icon

Ubuntu 20.04 focal/universe: Version 2.6.0.1-1build2 introduced

2020-01-07
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 reintroduced

2019-10-10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 removed

2019-10-10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 reintroduced

2019-10-10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 removed

2019-10-10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 reintroduced

2019-09-25
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 removed

2019-09-25
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 reintroduced

2019-09-25
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.6.0.1-1build2 removed

2019-09-25
Ubuntu icon

Ubuntu 19.10 eoan/universe: Updated from 2.5.4.1-3 to 2.6.0.1-1build2

2019-09-09
Ubuntu icon

Ubuntu 19.10 eoan-proposed/universe: Version 2.6.0.1-1build2 removed

2019-09-09
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.5.4.1-3 reintroduced

2019-09-06
  • Remove build dependency on non-existing libghc-edisoncore-dev. The correct package is libghc-edison-core-dev.
  • Remove build dependency on *-prof packages.
    No profiling package is being built.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.5.4.1-3 removed

2019-09-06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.5.4.1-3 reintroduced

2019-09-06
  • Remove build dependency on non-existing libghc-edisoncore-dev. The correct package is libghc-edison-core-dev.
  • Remove build dependency on *-prof packages.
    No profiling package is being built.

Related packages

agda - A dependently typed functional programming language and proof assistant
⇧ Top