Linux repositories inspector

createrepo - tool to generate the metadata for a yum repository

The createrepo tool generates the repodata directory and XML metadata that makes up a repository of RPM packages. This repository format is supported by apt-rpm, red-carpet(zen), smartpm, up2date, yast, and yum.
This package is similar to the apt-ftparchive or reprepro commands, but for working with RPM repositories.
0.10.4
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 15.1
OpenSUSE iconOpenSUSE Leap 15.2
0.10.3
Debian iconDebian 10.0
Debian iconDebian 9.0
Fedora iconFedora 28
Fedora iconFedora 29
Fedora iconFedora 30
OpenSUSE iconOpenSUSE Leap 42.3
Ubuntu iconUbuntu 17.10
Ubuntu iconUbuntu 18.04 LTS
Ubuntu iconUbuntu 18.10
Ubuntu iconUbuntu 19.04
Ubuntu iconUbuntu 19.10
Ubuntu iconUbuntu 16.04 LTS
0.9.9
CentOS iconCentOS 7.7.1908
DistributionVersionSincePackageInstalledPackager
CentOS iconCentOS 7.7.1908 osrpm0.9.9-28.el7Jan 0793.6 kiB302 kiBCentOS BuildSystem
Debian iconDebian 10.0 buster/maindeb0.10.3-12017-11-1047.7 kiB229 kiB
Debian iconDebian 9.0 stretch/maindeb0.10.3-12017-11-1047.7 kiB229 kiB
Fedora iconFedora 28 releases/Everything-osrpm0.10.3-15.fc282019-01-1499.6 kiB301 kiBFedora Project
Fedora iconFedora 29 releases/Everything-osrpm0.10.3-15.fc282019-01-1499.6 kiB301 kiBFedora Project
Fedora iconFedora 29 releases-test/Everything-osrpm0.10.3-15.fc282019-01-1499.6 kiB301 kiBFedora Project
Fedora iconFedora 30 releases/Everything-osrpm0.10.3-15.fc282019-06-1799.6 kiB301 kiBFedora Project
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm0.10.4-lp150.3.12019-01-1795.8 kiB321 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm0.10.4-lp151.4.22019-02-0695.7 kiB321 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.2 ossrpm0.10.4-lp152.5.4Mar 1993 kiB321 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 ossrpm0.10.3-7.42019-01-1781.6 kiB300 kiBhttp://bugs.opensuse.org
Ubuntu iconUbuntu 17.10 artful/universedeb0.10.3-12017-11-1034.2 kiB207 kiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb0.10.3-12017-11-1034.2 kiB207 kiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb0.10.3-12019-01-1434.2 kiB207 kiB
Ubuntu iconUbuntu 19.04 disco/universedeb0.10.3-12019-01-1434.2 kiB207 kiB
Ubuntu iconUbuntu 19.10 eoan/universedeb0.10.3-12019-06-1734.2 kiB207 kiB
Ubuntu iconUbuntu 16.04 LTS xenial/universedeb0.10.3-12017-11-1034.2 kiB207 kiB

Manual pages

mergerepo(1)

mergerepo - Merge multiple repositories together

mergerepo_yum(1)

mergerepo - Merge multiple repositories together

modifyrepo(1)

modifyrepo - Modify a repomd (xml-rpm-metadata) repository

modifyrepo_yum(1)

modifyrepo - Modify a repomd (xml-rpm-metadata) repository

createrepo(8)

createrepo - Create repomd (xml-rpm-metadata) repository

createrepo_yum(8)

createrepo - Create repomd (xml-rpm-metadata) repository

Latest updates

OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 0.10.4-lp152.5.3 to 0.10.4-lp152.5.4

Mar 19
  • Use SPDX3.0 license tags and package COPYING as %license.
Ubuntu icon

Ubuntu 20.04 focal/universe: Version 0.10.3-1 removed

Jan 14
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Version 0.10.4-lp152.5.3 introduced

Jan 07
  • Use SPDX3.0 license tags and package COPYING as %license.
CentOS icon

CentOS 7.7.1908 os: Version 0.9.9-28.el7 introduced

Jan 07
  • createrepo: allow xz and bz2 for xml files.
  • Resolves: bug#1125437
  • modifyrepo: fix handling of already compressed input.
  • Resolves: bug#1227782
  • modifyrepo: handle empty file with LZMA.
  • Resolves: bug#1287685
  • modifyrepo: docs: remove compat compress type.
  • Resolves: bug#1287714
Ubuntu icon

Ubuntu 20.04 focal/universe: Version 0.10.3-1 introduced

Jan 07
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Version 0.10.4-4.1 removed

Dec 06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 reintroduced

Oct 10
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 removed

Oct 10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 reintroduced

Oct 10
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 removed

Oct 10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 reintroduced

Sep 25
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 removed

Sep 25
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 reintroduced

Sep 25
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 removed

Sep 25
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 0.10.4-3.4 to 0.10.4-4.1

Sep 17
  • Use SPDX3.0 license tags and package COPYING as %license.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 reintroduced

Sep 06
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 removed

Sep 06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 reintroduced

Sep 06
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 removed

Sep 06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 0.10.3-1 reintroduced

Sep 06
  • New upstream release.
    • Ensure the -s/--checksum option is applied correctly. (Closes: #731147)
  • Drop patches applied upstream:
    • 01_fix-man-page-options.patch
    • 02_drop-unused-imports.patch
    • 03_fix-getting-YumAvailablePackage-local-path.patch
    • 04_fix-writing-additional-metadata.patch
    • 05_fix-handling-remote-packages.patch
  • Add Depends on python-lzma.
  • fix-version.patch: Fix version string reported by --version.
  • Update bash-completion support to install with pkg-config:
    • Add Build-Depends on pkg-config.
    • Let the buildsystem install createrepo.bash using pkg-config.
    • createrepo.maintscript: Remove obsolete bash-completion conffile.
  • Update Vcs-* control fields to new Git repository.
  • Use my @debian.org address.
  • Bump Standards-Version to 3.9.5. No changes needed.
⇧ Top