Linux repositories inspector

gvfs-backend-samba - VFS functionality for GLib -- Samba Support

This package provides a gvfs backend that supports Samba.
1.42.2
OpenSUSE iconOpenSUSE Tumbleweed
1.34.2.1
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 15.1
1.28.3
OpenSUSE iconOpenSUSE Leap 42.3
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm1.34.2.1-lp150.2.5Jan 17101 kiB116 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.34.2.1-lp150.3.6.1Feb 27102 kiB116 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.34.2.1-lp150.3.3.1Jan 18101 kiB116 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.34.2.1-lp150.3.10.1Jul 0760.5 kiB116 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm1.34.2.1-lp151.5.2Apr 0259.1 kiB116 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 update/ossrpm1.34.2.1-lp151.6.3.1Jul 0760.7 kiB116 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 ossrpm1.28.3-4.5Jan 1783.9 kiB87.6 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm1.28.3-5.3.1Jan 2184.3 kiB87.7 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm1.42.2-1.1Yesterday46.7 kiB95.5 kiBhttps://bugs.opensuse.org

Latest updates

OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.42.1-2.2 to 1.42.2-1.1

Yesterday
  • Update to version 1.42.2:
    • gdbus: Add workaround for deadlocks when cancelling jobs.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.42.1-2.1 to 1.42.1-2.2

Nov 18
  • Rebase SLE patches gvfs-nds.patch and gvfs-nvvfs.patch for version
    1. 42.1:
    2. Add daemon/nds.mount.in.
    3. Add daemon/nvvfs.mount.in.
    4. meson porting fixes.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.42.1-1.1 to 1.42.1-2.1

Nov 01
  • Rebase SLE patches gvfs-nds.patch and gvfs-nvvfs.patch for version
    1. 42.1:
    2. Add daemon/nds.mount.in.
    3. Add daemon/nvvfs.mount.in.
    4. meson porting fixes.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.40.2-1.2 to 1.42.1-1.1

Oct 21
  • Rebase SLE patches for version 1.42.1:
    • gvfs-nds.patch
    • gvfs-nvvfs.patch
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.40.2-1.1 to 1.40.2-1.2

Aug 07
  • Update to version 1.40.2:
    • daemon:
    • Only accept EXTERNAL authentication (CVE-2019-12795).
    • Check that the connecting client is the same user
      (CVE-2019-12795).
    • admin:
    • Ensure correct ownership when moving to file:// uri
      (CVE-2019-12449).
    • Use fsuid to ensure correct file ownership (CVE-2019-12447).
    • Allow changing file owner (CVE-2019-12447).
    • Add query_info_on_read/write functionality (CVE-2019-12448).
    • afc: Remove assumptions about length of device UUID to support new devices.
    • gmountsource: Fix deadlocks in synchronous API.
    • afp: Fix afp backend crash when no username supplied.
    • Updated translations.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.40.1-2.4 to 1.40.2-1.1

Jul 22
  • Update to version 1.40.2:
    • daemon:
    • Only accept EXTERNAL authentication (CVE-2019-12795).
    • Check that the connecting client is the same user
      (CVE-2019-12795).
    • admin:
    • Ensure correct ownership when moving to file:// uri
      (CVE-2019-12449).
    • Use fsuid to ensure correct file ownership (CVE-2019-12447).
    • Allow changing file owner (CVE-2019-12447).
    • Add query_info_on_read/write functionality (CVE-2019-12448).
    • afc: Remove assumptions about length of device UUID to support new devices.
    • gmountsource: Fix deadlocks in synchronous API.
    • afp: Fix afp backend crash when no username supplied.
    • Updated translations.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.40.1-2.3 to 1.40.1-2.4

Jul 16
  • Drop polkit rules files, only relevant for wheel group
    (boo#1125433).
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Updated from 1.34.2.1-lp150.3.6.1 to 1.34.2.1-lp150.3.10.1

Jul 07
  • Add gvfs-CVE-2019-12795.patch: Backport from upstream commit 70dbfc68 to check that the connecting client is the same user (boo#1137930, CVE-2019-12795).
OpenSUSE Leap 15.1 icon

OpenSUSE Leap 15.1 update/oss: Version 1.34.2.1-lp151.6.3.1 introduced

Jul 07
  • Add gvfs-CVE-2019-12795.patch: Backport from upstream commit 70dbfc68 to check that the connecting client is the same user (boo#1137930, CVE-2019-12795).
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.40.0-1.1 to 1.40.1-2.3

Jun 17
  • Drop polkit rules files, only relevant for wheel group
    (boo#1125433).
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.38.2-1.1 to 1.40.0-1.1

Apr 03
  • Update to version 1.40.0:
    • Stable release version bump.
OpenSUSE Leap 15.1 icon

OpenSUSE Leap 15.1 oss: Updated from 1.34.2.1-lp151.5.1 to 1.34.2.1-lp151.5.2

Apr 02
  • Add gvfs-CVE-2019-3827.patch: Prevent access if any authentication agent isn't available (glgo#GNOME/gvfs#355, bsc#1125084, CVE-2019-3827).
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.34.2.1-lp150.3.6.1 reintroduced

Mar 23
  • Add gvfs-CVE-2019-3827.patch: Prevent access if any authentication agent isn't available (glgo#GNOME/gvfs#355, bsc#1125084, CVE-2019-3827).
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.34.2.1-lp150.3.3.1 reintroduced

Mar 23
  • Add gvfs-smb-Use-O_RDWR-to-fix-fstat-when-writing.patch: Fix failures copying files on smb mounts (bgo#795805 boo#1096476).
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.34.2.1-lp150.3.6.1 removed

Mar 22
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.34.2.1-lp150.3.3.1 removed

Mar 22
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.38.1-2.1 to 1.38.2-1.1

Mar 15
  • Update to version 1.38.2:
    • mtp: Don't retry reading an event after failure.
    • admin: Prevent access if any authentication agent isn't available (CVE-2019-3827).
    • udisks2: Restore support of comment=x-gvfs-* option.
    • common: Prevent crashes on invalid autorun file.
    • Several smaller bugfixes.
    • Updated translations.
  • Drop gvfs-CVE-2019-3827.patch: Fixed upstream.
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Updated from 1.34.2.1-lp150.3.3.1 to 1.34.2.1-lp150.3.6.1

Feb 27
  • Add gvfs-CVE-2019-3827.patch: Prevent access if any authentication agent isn't available (glgo#GNOME/gvfs#355, bsc#1125084, CVE-2019-3827).
OpenSUSE Leap 15.1 icon

OpenSUSE Leap 15.1 oss: Updated from 1.34.2.1-lp151.4.5 to 1.34.2.1-lp151.5.1

Feb 26
  • Add gvfs-CVE-2019-3827.patch: Prevent access if any authentication agent isn't available (glgo#GNOME/gvfs#355, bsc#1125084, CVE-2019-3827).
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.38.1-1.4 to 1.38.1-2.1

Feb 25
  • Add gvfs-CVE-2019-3827.patch: Prevent access if any authentication agent isn't available (glgo#GNOME/gvfs#355, bsc#1125084, CVE-2019-3827).

Related packages

gvfs - Virtual File System functionality for GLib
samba - Server and Client software to interoperate with Windows machines
gvfs-backend-samba-debuginfo - Debug information for package gvfs-backend-samba
⇧ Top