Linux repositories inspector

libflatbuffers1-debuginfo - Debug information for package libflatbuffers1

This package provides debug information for package libflatbuffers1. Debug information is useful when developing applications that use this package or when debugging this package.
1.11.0
OpenSUSE iconOpenSUSE Leap 15.2
OpenSUSE iconOpenSUSE Tumbleweed
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Leap 15.2 debug/ossrpm1.11.0-lp152.3.6Mar 231.12 MiB4.96 MiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed debug/ossrpm1.11.0-3.2Mar 111.06 MiB6.11 MiBhttps://bugs.opensuse.org

Latest updates

OpenSUSE icon

OpenSUSE Leap 15.2 debug/oss: Updated from 1.11.0-lp152.3.4 to 1.11.0-lp152.3.6

Mar 23
  • Fix build: RPM 4.15 got a bit stricter and fails on find-provides script errors. Earlier RPM versions ignored it. In this specic case it turns out that the .cmake file installed is invalid, as it contained set(PACKAGE_VERSION "..") (so RPM is right to abort). Turns out that upstream simply did not really cater for the fact that this could be installed from tarball and not from a git checkout: they use 'git describe' to inject a version into the .cmake file. Fix this by replacing the placeholders using sed, injecting the rpm %version there.
OpenSUSE icon

OpenSUSE Leap 15.2 debug/oss: Updated from 1.11.0-lp152.3.1 to 1.11.0-lp152.3.4

Mar 15
  • Fix build: RPM 4.15 got a bit stricter and fails on find-provides script errors. Earlier RPM versions ignored it. In this specic case it turns out that the .cmake file installed is invalid, as it contained set(PACKAGE_VERSION "..") (so RPM is right to abort). Turns out that upstream simply did not really cater for the fact that this could be installed from tarball and not from a git checkout: they use 'git describe' to inject a version into the .cmake file. Fix this by replacing the placeholders using sed, injecting the rpm %version there.
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.11.0-3.1 to 1.11.0-3.2

Mar 11
  • Fix build: RPM 4.15 got a bit stricter and fails on find-provides script errors. Earlier RPM versions ignored it. In this specic case it turns out that the .cmake file installed is invalid, as it contained set(PACKAGE_VERSION "..") (so RPM is right to abort). Turns out that upstream simply did not really cater for the fact that this could be installed from tarball and not from a git checkout: they use 'git describe' to inject a version into the .cmake file. Fix this by replacing the placeholders using sed, injecting the rpm %version there.
OpenSUSE icon

OpenSUSE Leap 15.2 debug/oss: Updated from 1.11.0-lp152.2.5 to 1.11.0-lp152.3.1

Feb 24
  • Fix build: RPM 4.15 got a bit stricter and fails on find-provides script errors. Earlier RPM versions ignored it. In this specic case it turns out that the .cmake file installed is invalid, as it contained set(PACKAGE_VERSION "..") (so RPM is right to abort). Turns out that upstream simply did not really cater for the fact that this could be installed from tarball and not from a git checkout: they use 'git describe' to inject a version into the .cmake file. Fix this by replacing the placeholders using sed, injecting the rpm %version there.
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.11.0-2.1 to 1.11.0-3.1

Feb 21
  • Fix build: RPM 4.15 got a bit stricter and fails on find-provides script errors. Earlier RPM versions ignored it. In this specic case it turns out that the .cmake file installed is invalid, as it contained set(PACKAGE_VERSION "..") (so RPM is right to abort). Turns out that upstream simply did not really cater for the fact that this could be installed from tarball and not from a git checkout: they use 'git describe' to inject a version into the .cmake file. Fix this by replacing the placeholders using sed, injecting the rpm %version there.
OpenSUSE icon

OpenSUSE Leap 15.2 debug/oss: Updated from 1.11.0-lp152.2.3 to 1.11.0-lp152.2.5

Feb 04
  • Use %cmake_build to build the cmake stuff
OpenSUSE icon

OpenSUSE Leap 15.2 debug/oss: Updated from 1.11.0-lp152.2.2 to 1.11.0-lp152.2.3

Jan 17
  • Use %cmake_build to build the cmake stuff
OpenSUSE icon

OpenSUSE Leap 15.2 debug/oss: Version 1.11.0-lp152.2.2 introduced

Jan 07
  • Use %cmake_build to build the cmake stuff
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.11.0-1.3 to 1.11.0-2.1

Dec 07
  • Use %cmake_build to build the cmake stuff
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.11.0-1.2 to 1.11.0-1.3

Nov 18
  • Update to 1.11.0
    • More accurate C++ float handling, NaN handling, limit checking.
    • Java optimization: faster object accessors, faster UTF8 conversion.
    • A lot of Rust port improvements.
    • Vector of union JSON parsing.
    • Parser can now work from binary schemas.
    • Python: numpy vector support.
    • Packaging: Snap & RPM support.
    • Many improvements to our CI, added Bazel CI, dockerized language tests.
    • Many other fixes and smaller improvements, 169 commits since
      1. 10.0
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.10.0.20190321T162332.a746143-1.4 to 1.11.0-1.2

Oct 24
  • Update to 1.11.0
    • More accurate C++ float handling, NaN handling, limit checking.
    • Java optimization: faster object accessors, faster UTF8 conversion.
    • A lot of Rust port improvements.
    • Vector of union JSON parsing.
    • Parser can now work from binary schemas.
    • Python: numpy vector support.
    • Packaging: Snap & RPM support.
    • Many improvements to our CI, added Bazel CI, dockerized language tests.
    • Many other fixes and smaller improvements, 169 commits since
      1. 10.0
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.10.0.20190321T162332.a746143-1.3 to 1.10.0.20190321T162332.a746143-1.4

2019-07-16
  • Update to 20190321T162332.a746143 to fix bigendian build
  • dropped remove-date-from-flatc-version.patch
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.10.0.20190321T162332.a746143-1.1 to 1.10.0.20190321T162332.a746143-1.3

2019-06-19
  • Update to 20190321T162332.a746143 to fix bigendian build
  • dropped remove-date-from-flatc-version.patch
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Updated from 1.10.0-1.1 to 1.10.0.20190321T162332.a746143-1.1

2019-04-02
  • Update to 20190321T162332.a746143 to fix bigendian build
  • dropped remove-date-from-flatc-version.patch
OpenSUSE icon

OpenSUSE Tumbleweed debug/oss: Version 1.10.0-1.1 introduced

2019-03-30
  • Update to 1.10.0
    • Rust support
    • Dart support
    • Lua support
    • Lobster support
    • C++
      • Improved / more correct verifier
      • compare operator in generated code
      • new/improved move operators for many data types
      • string_view support.
    • Java & C# support vectors of unions.
    • Many other fixes and smaller improvements
  • Package shared library in accordance with shared library packaging policy.
  • Remove upstream-included 0001-remove-unnecessary-const-qualifier.patch
  • Rebase remove-date-from-flatc-version.patch

Related packages

libflatbuffers1 - efficient cross platform serialization library - shared library
⇧ Top