Linux repositories inspector

libpoppler-qt4-4 - PDF rendering library (Qt 4 based shared library)

Poppler is a PDF rendering library based on Xpdf PDF viewer.
This package provides the Qt 4 based shared library for applications using the Qt 4 interface to Poppler.
0.57.0
Ubuntu iconUbuntu 17.10
0.48.0
Debian iconDebian 9.0
0.43.0
OpenSUSE iconOpenSUSE Leap 42.3
0.41.0
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 9.0 stretch/maindeb0.48.0-2+deb9u22018-03-14133 kiB487 kiB
OpenSUSE iconOpenSUSE Leap 42.3 ossrpm0.43.0-3.12019-01-17188 kiB458 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm0.43.0-8.12019-01-21193 kiB454 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm0.43.0-5.12019-01-21189 kiB458 kiBhttp://bugs.opensuse.org
Ubuntu iconUbuntu 17.10 artful/universedeb0.57.0-2ubuntu42017-11-10117 kiB478 kiB
Ubuntu iconUbuntu 17.10 artful-security/universedeb0.57.0-2ubuntu4.32018-06-12117 kiB479 kiB
Ubuntu iconUbuntu 17.10 artful-updates/universedeb0.57.0-2ubuntu4.32018-06-12117 kiB479 kiB
Ubuntu iconUbuntu 16.04 LTS xenial/maindeb0.41.0-0ubuntu12017-11-10113 kiB469 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-security/maindeb0.41.0-0ubuntu1.142019-06-27113 kiB471 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-updates/maindeb0.41.0-0ubuntu1.142019-06-27113 kiB471 kiB

Latest updates

Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 0.41.0-0ubuntu1.14 reintroduced

2019-10-02
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 0.41.0-0ubuntu1.14 removed

2019-10-02
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 0.41.0-0ubuntu1.14 reintroduced

2019-08-15
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 0.41.0-0ubuntu1.14 removed

2019-08-15
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Version 0.41.0-0ubuntu1.14 reintroduced

2019-08-02
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 0.41.0-0ubuntu1.14 reintroduced

2019-08-02
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Version 0.41.0-0ubuntu1.14 removed

2019-08-02
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 0.41.0-0ubuntu1.14 removed

2019-08-02
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Updated from 0.41.0-0ubuntu1.13 to 0.41.0-0ubuntu1.14

2019-06-27
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Updated from 0.41.0-0ubuntu1.13 to 0.41.0-0ubuntu1.14

2019-06-27
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Updated from 0.41.0-0ubuntu1.12 to 0.41.0-0ubuntu1.13

2019-03-11
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Updated from 0.41.0-0ubuntu1.12 to 0.41.0-0ubuntu1.13

2019-03-11
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Updated from 0.41.0-0ubuntu1.11 to 0.41.0-0ubuntu1.12

2019-02-11
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Updated from 0.41.0-0ubuntu1.11 to 0.41.0-0ubuntu1.12

2019-02-11
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Updated from 0.41.0-0ubuntu1.10 to 0.41.0-0ubuntu1.11

2019-01-22
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Updated from 0.41.0-0ubuntu1.10 to 0.41.0-0ubuntu1.11

2019-01-22
OpenSUSE icon

OpenSUSE Leap 42.3 update/oss: Updated from 0.43.0-5.1 to 0.43.0-8.1

2019-01-21
  • Apply 0001-Fix-crash-in-malformed-document.patch from upstream to fix a division-by-zero exception in the ImageStream object constructor. This issue is triggered by the same exploit as CVE-2017-14617. [bsc#1060220]
  • Apply 0001-Check-for-XRefEntry-existing-before-using-it.patch from upstream to fix a segmentation fault in the Hints object constructor. This issue is triggered by the same exploit as CVE-2017-14517. [bsc#1059066]
  • Apply CVE-2017-1000456.patch from upstream to fix an issue where TextPool::addWord() failed to validate the integer boundaries, leading to overflow errors in subsequent calculations.
    CVE-2017-1000456, bsc#1074453.
  • Apply CVE-2017-15565.patch from upstream to fix a NULL pointer dereference vulnerability in the GfxImageColorMap::getGrayLine() function via a crafted PDF document. [CVE-2017-15565,
    bsc#1064593]
  • Update license attribute to conform to the latest SPDX version.
OpenSUSE icon

OpenSUSE Leap 42.3 update/oss: Version 0.43.0-5.1 introduced

2019-01-21
  • Apply CVE-2017-9775.patch from upstream to fix a stack overflow bug in pdftocairo that could have been exploited in a denial of service attack through a specially crafted PDF document.
    bsc#1045719, CVE-2017-9775
  • Apply CVE-2017-9776.patch from upstream to fix an integer overflow bug that could have been exploited in a denial of service attack through a specially crafted PDF document.
    bsc#1045721, CVE-2017-9776
  • Apply CVE-2017-7515.patch to fix a memory leak that occurred when the parser tried to recover from a broken input file.
    bsc#1043088, CVE-2017-7515
OpenSUSE icon

OpenSUSE Leap 42.3 oss: Version 0.43.0-3.1 introduced

2019-01-17
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Updated from 0.41.0-0ubuntu1.7 to 0.41.0-0ubuntu1.10

2019-01-12

Related packages

libpoppler-qt4-4-32bit - PDF Rendering Library - Qt4 Wrapper
libpoppler-qt4-4-debuginfo - Debug information for package libpoppler-qt4-4
libpoppler-qt4-4-debuginfo-32bit - Debug information for package libpoppler-qt4-4
⇧ Top