Linux repositories inspector

libqt5core5a - Qt 5 core module

Qt is a cross-platform C++ application framework. Qt's primary feature is its rich set of widgets that provide standard GUI functionality.
The QtCore module contains core non-GUI functionality.
5.14.1
Debian iconDebian experimental
5.12.5
Ubuntu iconUbuntu 20.04
5.12.4
Ubuntu iconUbuntu 19.10
5.12.2
Ubuntu iconUbuntu 19.04
5.11.3
Debian iconDebian 10.0
5.11.1
KDE Neon iconKDE Neon Dev stable
KDE Neon iconKDE Neon Dev unstable
KDE Neon iconKDE Neon User
Ubuntu iconUbuntu 18.10
5.9.5
Ubuntu iconUbuntu 18.04 LTS
5.9.1
Ubuntu iconUbuntu 17.10
5.7.1
Debian iconDebian 9.0
5.5.1
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb5.11.3+dfsg1-1+deb10u22020-02-081.85 MiB5.4 MiB
Debian iconDebian 10.0 buster-proposed-updates/maindeb5.11.3+dfsg1-1+deb10u32020-02-081.85 MiB5.4 MiB
Debian iconDebian experimental experimental/maindeb5.14.1+dfsg-32020-02-181.7 MiB5.66 MiB
Debian iconDebian 9.0 stretch/maindeb5.7.1+dfsg-3+deb9u12019-06-171.75 MiB5.21 MiB
Debian iconDebian 9.0 stretch-proposed-updates/maindeb5.7.1+dfsg-3+deb9u22020-02-081.75 MiB5.21 MiB
KDE Neon iconKDE Neon Dev stable xenial/maindeb5.11.1+dfsg-2+16.04+xenial+build572019-01-141.81 MiB5.11 MiB
KDE Neon iconKDE Neon Dev unstable xenial/maindeb5.11.1+dfsg-2+16.04+xenial+build572019-01-141.81 MiB5.11 MiB
KDE Neon iconKDE Neon User xenial/maindeb5.11.1+dfsg-2+16.04+xenial+build572019-01-141.81 MiB5.11 MiB
KDE Neon iconKDE Neon User xenial/maindeb5.11.1+dfsg-2+16.04+xenial+build562019-01-141.81 MiB5.11 MiB
Ubuntu iconUbuntu 17.10 artful/maindeb5.9.1+dfsg-10ubuntu12017-11-101.95 MiB5.71 MiB
Ubuntu iconUbuntu 18.04 LTS bionic/maindeb5.9.5+dfsg-0ubuntu12018-06-121.94 MiB5.72 MiB
Ubuntu iconUbuntu 18.04 LTS bionic-security/maindeb5.9.5+dfsg-0ubuntu2.52020-02-101.94 MiB5.72 MiB
Ubuntu iconUbuntu 18.04 LTS bionic-updates/maindeb5.9.5+dfsg-0ubuntu2.52020-02-101.94 MiB5.72 MiB
Ubuntu iconUbuntu 18.10 cosmic/maindeb5.11.1+dfsg-7ubuntu12019-01-141.96 MiB5.81 MiB
Ubuntu iconUbuntu 18.10 cosmic-security/maindeb5.11.1+dfsg-7ubuntu3.12019-06-171.96 MiB5.81 MiB
Ubuntu iconUbuntu 18.10 cosmic-updates/maindeb5.11.1+dfsg-7ubuntu3.12019-06-171.96 MiB5.81 MiB
Ubuntu iconUbuntu 19.04 disco/universedeb5.12.2+dfsg-4ubuntu12019-06-171.89 MiB5.6 MiB
Ubuntu iconUbuntu 19.04 disco-updates/universedeb5.12.2+dfsg-4ubuntu1.12019-09-021.89 MiB5.6 MiB
Ubuntu iconUbuntu 19.10 eoan/universedeb5.12.4+dfsg-4ubuntu12019-10-031.91 MiB5.72 MiB
Ubuntu iconUbuntu 19.10 eoan-security/universedeb5.12.4+dfsg-4ubuntu1.12020-02-101.91 MiB5.72 MiB
Ubuntu iconUbuntu 19.10 eoan-updates/universedeb5.12.4+dfsg-4ubuntu1.12020-02-101.91 MiB5.72 MiB
Ubuntu iconUbuntu 20.04 focal/universedeb5.12.5+dfsg-9build12020-03-241.91 MiB5.73 MiB
Ubuntu iconUbuntu 16.04 LTS xenial/maindeb5.5.1+dfsg-16ubuntu72017-11-101.73 MiB5.18 MiB
Ubuntu iconUbuntu 16.04 LTS xenial-security/maindeb5.5.1+dfsg-16ubuntu7.72020-02-101.73 MiB5.18 MiB
Ubuntu iconUbuntu 16.04 LTS xenial-updates/maindeb5.5.1+dfsg-16ubuntu7.72020-02-101.73 MiB5.18 MiB

Latest updates

Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-9build1 removed

2020-03-24
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 5.12.5+dfsg-8build1 to 5.12.5+dfsg-9build1

2020-03-24
  • No-change rebuild for icu soname change.
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Updated from 5.12.5+dfsg-9 to 5.12.5+dfsg-9build1

2020-03-04
  • No-change rebuild for icu soname change.
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-9 introduced

2020-02-28
Dmitry Shachnev
  • Backport upstream patch to add an expansion limit for XML entities (CVE-2015-9541, closes: #951066).
    • Add two new symbols to debian/libqt5core5a.symbols.
    Helmut Grohne
    • qmake cross wrapper should pass QMAKE_STRIP. (Closes: #950507)
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-8build1 removed

2020-02-27
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 5.12.5+dfsg-8 to 5.12.5+dfsg-8build1

2020-02-27
  • No-change rebuild for icu soname change.
Debian icon

Debian experimental experimental/main: Updated from 5.14.1+dfsg-2 to 5.14.1+dfsg-3

2020-02-18
Jonathan Riddell
  • Make qtbase5-private-dev depend upon libfontconfig1-dev as expected by Qt5FontDatabaseSupportConfig.cmake.
Dmitry Shachnev
  • Make libmd4c a private dependency of Qt GUI.
Debian icon

Debian experimental experimental/main: Updated from 5.14.1+dfsg-1 to 5.14.1+dfsg-2

2020-02-17
  • Update debian/libqt5core5a.symbols from buildds’ logs.
Debian icon

Debian experimental experimental/main: Version 5.14.1+dfsg-1 introduced

2020-02-17
Lisandro Damián Nicanor Pérez Meyer
  • New upstream release.
    • Bump ABI version to qtbase-abi-5-14-1.
    • Bump Build-Depends-Indep versions.
  • Remove patches already applied upstream:
    • mysql_free_results_when_qsqlquery_finished_is_called.patch
    • qdockwidget_undocked_notification.diff
    • docs_fixes.diff
    • postgresql_12.diff
    • uic_global_includes.diff
    • riscv.diff
  • Refresh patches:
    • gnukfreebsd.diff
    • gnukfreebsd_linker_warnings.diff
    • nonlinux_utime.diff
    • qdoc_default_incdirs.diff
  • Add libmd4c-dev as a build dependency, required for markdown support.
Dmitry Shachnev
  • Update path to qbytearray/rfc3252.txt in Files-Excluded list.
  • Update debian/copyright using debian/scripts/update-copyright.
  • debian/scripts/update-copyright: Correctly handle repeating authors in the same file.
  • Update symbols files from the current build logs.
  • Build-depend on libzstd-dev.
  • Build with -no-mimetype-database, and make libqt5core5a depend on shared-mime-info (as suggested by upstream).
  • Add one more RFC file to Files-Excluded.
  • Add more tags files to debian/qtbase5-doc-dev.install.
  • Update to debhelper compat level 12, use the new syntax.
  • Stop passing -V to dh_makeshlibs, it is now the default behavior.
  • Manually update the non-generated part of debian/copyright.
Alexander Volkov
  • Update install files for the new version.
Helmut Grohne
  • qmake cross wrapper should pass QMAKE_STRIP. (Closes: #950507)
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-8build1 introduced

2020-02-13
  • No-change rebuild for icu soname change.
Ubuntu icon

Ubuntu 18.04 LTS bionic-updates/main: Updated from 5.9.5+dfsg-0ubuntu2.4 to 5.9.5+dfsg-0ubuntu2.5

2020-02-10
  • SECURITY UPDATE: division-by-zero via malformed PPM image
    • debian/patches/CVE-2018-19872.patch: add extra check to src/gui/image/qppmhandler.cpp.
    • CVE-2018-19872
  • SECURITY UPDATE: QPluginLoader loads plugins from the CWD
    • debian/patches/CVE-2020-0569.patch: do not load plugin from the $PWD in src/corelib/plugin/qpluginloader.cpp.
    • CVE-2020-0569
Ubuntu icon

Ubuntu 19.10 eoan-updates/universe: Version 5.12.4+dfsg-4ubuntu1.1 introduced

2020-02-10
  • SECURITY UPDATE: DoS via text file containing many directional chars
    • debian/patches/CVE-2019-18281.patch: add bounds check to src/gui/text/qtextengine.cpp.
    • CVE-2019-18281
  • SECURITY UPDATE: QPluginLoader loads plugins from the CWD
    • debian/patches/CVE-2020-0569.patch: do not load plugin from the $PWD in src/corelib/plugin/qpluginloader.cpp.
    • CVE-2020-0569
  • SECURITY UPDATE: QLibrary loads libraries from relative path from CWD
    • debian/patches/CVE-2020-0570.patch: do not attempt to load a library relative to $PWD in src/corelib/plugin/qlibrary_unix.cpp.
    • CVE-2020-0570
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Updated from 5.5.1+dfsg-16ubuntu7.6 to 5.5.1+dfsg-16ubuntu7.7

2020-02-10
  • SECURITY UPDATE: division-by-zero via malformed PPM image
    • debian/patches/CVE-2018-19872.patch: add extra check to src/gui/image/qppmhandler.cpp.
    • CVE-2018-19872
  • SECURITY UPDATE: QPluginLoader loads plugins from the CWD
    • debian/patches/CVE-2020-0569.patch: do not load plugin from the $PWD in src/corelib/plugin/qpluginloader.cpp.
    • CVE-2020-0569
Ubuntu icon

Ubuntu 18.04 LTS bionic-security/main: Updated from 5.9.5+dfsg-0ubuntu2.1 to 5.9.5+dfsg-0ubuntu2.5

2020-02-10
  • SECURITY UPDATE: division-by-zero via malformed PPM image
    • debian/patches/CVE-2018-19872.patch: add extra check to src/gui/image/qppmhandler.cpp.
    • CVE-2018-19872
  • SECURITY UPDATE: QPluginLoader loads plugins from the CWD
    • debian/patches/CVE-2020-0569.patch: do not load plugin from the $PWD in src/corelib/plugin/qpluginloader.cpp.
    • CVE-2020-0569
Ubuntu icon

Ubuntu 19.10 eoan-security/universe: Version 5.12.4+dfsg-4ubuntu1.1 introduced

2020-02-10
  • SECURITY UPDATE: DoS via text file containing many directional chars
    • debian/patches/CVE-2019-18281.patch: add bounds check to src/gui/text/qtextengine.cpp.
    • CVE-2019-18281
  • SECURITY UPDATE: QPluginLoader loads plugins from the CWD
    • debian/patches/CVE-2020-0569.patch: do not load plugin from the $PWD in src/corelib/plugin/qpluginloader.cpp.
    • CVE-2020-0569
  • SECURITY UPDATE: QLibrary loads libraries from relative path from CWD
    • debian/patches/CVE-2020-0570.patch: do not attempt to load a library relative to $PWD in src/corelib/plugin/qlibrary_unix.cpp.
    • CVE-2020-0570
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Updated from 5.5.1+dfsg-16ubuntu7.6 to 5.5.1+dfsg-16ubuntu7.7

2020-02-10
  • SECURITY UPDATE: division-by-zero via malformed PPM image
    • debian/patches/CVE-2018-19872.patch: add extra check to src/gui/image/qppmhandler.cpp.
    • CVE-2018-19872
  • SECURITY UPDATE: QPluginLoader loads plugins from the CWD
    • debian/patches/CVE-2020-0569.patch: do not load plugin from the $PWD in src/corelib/plugin/qpluginloader.cpp.
    • CVE-2020-0569
Debian icon

Debian 10.0 buster-proposed-updates/main: Version 5.11.3+dfsg1-1+deb10u3 introduced

2020-02-08
Dmitry Shachnev
  • Backport fixes for two vulnerabilities:
    • CVE-2020-0569: Do not load plugin from the CWD.
    • CVE-2020-0570: Qt tries to load invalid library from CWD.
Debian icon

Debian 9.0 stretch-proposed-updates/main: Version 5.7.1+dfsg-3+deb9u2 introduced

2020-02-08
  • Backport fix for CVE-2020-0569: Do not load plugin from the CWD.
Debian icon

Debian 10.0 buster-proposed-updates/main: Version 5.11.3+dfsg1-1+deb10u2 removed

2020-02-08
Debian icon

Debian 10.0 buster/main: Updated from 5.11.3+dfsg1-1+deb10u1 to 5.11.3+dfsg1-1+deb10u2

2020-02-08
Dmitry Shachnev
  • Backport upstream patch to add support for non-PPD printers and avoid silent fallback to a printer supporting PPD (closes: #911702, #911844).
  • Backport upstream patch to fix crash in QStyleSheetStyle::repolish() when using QLabels with rich text (closes: #935909).
Melvin Vermeeren
  • Backport upstream patch to fix graphics tablet hover events (closes: #935627).

Related packages

libqt5core5a-dbgsym - Debug symbols for libqt5core5a
⇧ Top