Linux repositories inspector

libslp1 - An Implementation of the Service Location Protocol V2

Service Location Protocol is an IETF standard protocol that is used to discover/advertise services on the network. You can use SLP for anything from locating a suitable printer on your floor to discovering what LDAP directories are available in your organization.
This package provides the OpenSLP run-time library package that is linked to SLP aware applications. This library implements RFC 2614 - An API for Service Location. Unless there is a SLP DA in the network, you must install the slpd package to be able to advertise the services.
Original maintainer
Homepagehttp://www.openslp.org/
2.0.0
OpenSUSE iconOpenSUSE Tumbleweed
1.2.1
Ubuntu iconUbuntu 17.10
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Tumbleweed ossrpm2.0.0-17.22020-02-0955 kiB87 kiBhttps://bugs.opensuse.org
Ubuntu iconUbuntu 17.10 artful/universedeb1.2.1-112017-11-1039.4 kiB106 kiB
Ubuntu iconUbuntu 17.10 artful-security/universedeb1.2.1-11ubuntu0.17.10.12019-01-1239.8 kiB106 kiB
Ubuntu iconUbuntu 17.10 artful-updates/universedeb1.2.1-11ubuntu0.17.10.12019-01-1239.8 kiB106 kiB
Ubuntu iconUbuntu 16.04 LTS xenial/maindeb1.2.1-112017-11-1039.4 kiB106 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-security/maindeb1.2.1-11ubuntu0.16.04.12019-01-1239.5 kiB106 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-updates/maindeb1.2.1-11ubuntu0.16.04.12019-01-1239.5 kiB106 kiB

Latest updates

OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 2.0.0-17.1 to 2.0.0-17.2

2020-02-09
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 1.2.1-11ubuntu0.16.04.1 reintroduced

2019-10-02
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 1.2.1-11ubuntu0.16.04.1 removed

2019-10-02
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 2.0.0-16.2 to 2.0.0-17.1

2019-08-25
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 1.2.1-11ubuntu0.16.04.1 reintroduced

2019-08-15
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 1.2.1-11ubuntu0.16.04.1 removed

2019-08-15
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Version 1.2.1-11ubuntu0.16.04.1 reintroduced

2019-08-02
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 1.2.1-11ubuntu0.16.04.1 reintroduced

2019-08-02
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Version 1.2.1-11ubuntu0.16.04.1 removed

2019-08-02
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 1.2.1-11ubuntu0.16.04.1 removed

2019-08-02
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 2.0.0-16.1 to 2.0.0-16.2

2019-07-16
  • Explicitely require library on develpackage and do not pull in the base package with slptool binary
OpenSUSE icon

OpenSUSE Tumbleweed oss: Version 2.0.0-16.1 introduced

2019-06-17
  • Explicitely require library on develpackage and do not pull in the base package with slptool binary
Ubuntu icon

Ubuntu 17.10 artful-updates/universe: Version 1.2.1-11ubuntu0.17.10.1 introduced

2019-01-12
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 17.10 artful-security/universe: Version 1.2.1-11ubuntu0.17.10.1 introduced

2019-01-12
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 16.04 LTS xenial-updates/main: Version 1.2.1-11ubuntu0.16.04.1 introduced

2019-01-12
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 16.04 LTS xenial-security/main: Version 1.2.1-11ubuntu0.16.04.1 introduced

2019-01-12
  • SECURITY UPDATE: DoS or code exec via double-free
    • debian/patches/CVE-2017-17833.patch: fix up local copy of pointer in slpd/slpd_process.c.
    • CVE-2017-17833
    • CVE-2018-12938
Ubuntu icon

Ubuntu 18.04 LTS bionic/universe: Version 1.2.1-11 removed

2018-06-19
Ubuntu icon

Ubuntu 18.04 LTS bionic/universe: Version 1.2.1-11 introduced

2017-11-10
  • QA upload from the Security Team
  • Fix double free as per CVE-2015-5177
Ubuntu icon

Ubuntu 17.10 artful/universe: Version 1.2.1-11 introduced

2017-11-10
  • QA upload from the Security Team
  • Fix double free as per CVE-2015-5177
Ubuntu icon

Ubuntu 16.04 LTS xenial/main: Version 1.2.1-11 introduced

2017-11-10
  • QA upload from the Security Team
  • Fix double free as per CVE-2015-5177

Related packages

libslp1-debuginfo - Debug information for package libslp1
⇧ Top