Linux repositories inspector

libsndfile1-32bit - A Library to Handle Various Audio File Formats

Libsndfile is a C library for reading and writing sound files, such as AIFF, AU, and WAV files, through one standard interface. It can currently read and write 8, 16, 24, and 32-bit PCM files as well as 32-bit floating point WAV files and a number of compressed formats.
1.0.28
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 15.1
OpenSUSE iconOpenSUSE Leap 15.2
OpenSUSE iconOpenSUSE Tumbleweed
1.0.25
OpenSUSE iconOpenSUSE Leap 42.3
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm1.0.28-lp150.2.52019-01-17201 kiB575 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.0.28-lp150.3.3.12019-01-18201 kiB575 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm1.0.28-lp151.4.32019-01-23201 kiB575 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.2 ossrpm1.0.28-lp152.5.32020-01-07199 kiB575 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 ossrpm1.0.25-29.12019-01-17148 kiB451 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm1.0.25-34.12019-01-21150 kiB451 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm1.0.25-31.12019-01-21149 kiB451 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm1.0.28-10.22020-02-09197 kiB539 kiBhttps://bugs.opensuse.org

Latest updates

OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.0.28-10.1 to 1.0.28-10.2

2020-02-09
  • Remove build dependencies for progs subpackage from library:
    • alsa-devel, only needed for the examples
    • sqlite3-devel, only needed for the regression test
  • Only build library, pass --disable-full-suite to configure
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Version 1.0.28-lp152.5.3 introduced

2020-01-07
  • Fix buffer overflow in sndfile-deinterlace, which isn't really a security issue (bsc#1100167, CVE-2018-13139): sndfile-deinterlace-channels-check.patch
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.0.28-9.4 to 1.0.28-10.1

2019-12-13
  • Remove build dependencies for progs subpackage from library:
    • alsa-devel, only needed for the examples
    • sqlite3-devel, only needed for the regression test
  • Only build library, pass --disable-full-suite to configure
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.0.28-9.3 to 1.0.28-9.4

2019-07-16
  • Fix segfault in wav conversion due to the invalid loop count (CVE-2018-19758, bsc#1117954): libsndfile-wav-loop-count-fix.patch
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.0.28-9.1 to 1.0.28-9.3

2019-06-17
  • Fix segfault in wav conversion due to the invalid loop count (CVE-2018-19758, bsc#1117954): libsndfile-wav-loop-count-fix.patch
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 1.0.28-lp150.3.3.1 reintroduced

2019-03-23
  • Fix buffer overflow in sndfile-deinterlace, which isn't really a security issue (bsc#1100167, CVE-2018-13139): sndfile-deinterlace-channels-check.patch
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 1.0.28-lp150.3.3.1 removed

2019-03-22
OpenSUSE icon

OpenSUSE Leap 15.1 oss: Version 1.0.28-lp151.4.3 introduced

2019-01-23
  • Fix buffer overflow in sndfile-deinterlace, which isn't really a security issue (bsc#1100167, CVE-2018-13139): sndfile-deinterlace-channels-check.patch
OpenSUSE icon

OpenSUSE Leap 42.3 update/oss: Updated from 1.0.25-31.1 to 1.0.25-34.1

2019-01-21
  • Fix buffer overflow in sndfile-deinterlace, which isn't really a security issue (bsc#1100167, CVE-2018-13139): sndfile-deinterlace-channels-check.patch
OpenSUSE icon

OpenSUSE Leap 42.3 update/oss: Version 1.0.25-31.1 introduced

2019-01-21
  • Fix VUL-0: divide-by-zero error exists in the function double64_init() in double64.c (CVE-2017-14634, bsc#1059911): 0020-src-float32-double64-.c-Fix-potential-divide-by-0.patch 0030-double64_init-Check-psf-sf.channels-against-upper-bo.patch
  • Tentative fix for VUL-0: out of bounds read in the function d2alaw_array() in alaw.c (CVE-2017-14245, bsc#1059912) and VUL-0: out of bounds read in the function d2ulaw_array() in ulaw.c (CVE-2017-14246, bsc#1059913): 0031-sfe_copy_data_fp-check-value-of-max-variable.patch
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 1.0.28-lp150.3.3.1 introduced

2019-01-18
  • Fix buffer overflow in sndfile-deinterlace, which isn't really a security issue (bsc#1100167, CVE-2018-13139): sndfile-deinterlace-channels-check.patch
OpenSUSE icon

OpenSUSE Leap 15.0 oss: Version 1.0.28-lp150.2.5 introduced

2019-01-17
  • Fix VUL-0: divide-by-zero error exists in the function double64_init() in double64.c (CVE-2017-14634, bsc#1059911): 0030-double64_init-Check-psf-sf.channels-against-upper-bo.patch
  • Tentative fix for VUL-0: out of bounds read in the function d2alaw_array() in alaw.c (CVE-2017-14245, bsc#1059912) and VUL-0: out of bounds read in the function d2ulaw_array() in ulaw.c (CVE-2017-14246, bsc#1059913): 0031-sfe_copy_data_fp-check-value-of-max-variable.patch
OpenSUSE icon

OpenSUSE Leap 42.3 oss: Version 1.0.25-29.1 introduced

2019-01-17
OpenSUSE icon

OpenSUSE Tumbleweed oss: Version 1.0.28-9.1 introduced

2019-01-17
  • Fix segfault in wav conversion due to the invalid loop count (CVE-2018-19758, bsc#1117954): libsndfile-wav-loop-count-fix.patch

Related packages

libsndfile1 - A Library to Handle Various Audio File Formats
libsndfile1-32bit-debuginfo - Debug information for package libsndfile1
⇧ Top