Linux repositories inspector

libsynctex2 - TeX Live: SyncTeX parser library

Library for SyncTeX parsing support.
2020.20200313.54259
Debian iconDebian experimental
2019.20190605.51237
Ubuntu iconUbuntu 19.10
Ubuntu iconUbuntu 20.04
2018.20181218.49446
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
2018.20180824.48463
Ubuntu iconUbuntu 18.10
1.21
OpenSUSE iconOpenSUSE Tumbleweed
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb2018.20181218.49446-12019-01-1278.6 kiB188 kiB
Debian iconDebian experimental experimental/maindeb2020.20200313.54259-22020-03-1680.2 kiB190 kiB
OpenSUSE iconOpenSUSE Tumbleweed ossrpm1.21-67.22020-03-2266.8 kiB117 kiBhttps://bugs.opensuse.org
Ubuntu iconUbuntu 18.10 cosmic/maindeb2018.20180824.48463-12019-01-1453.1 kiB188 kiB
Ubuntu iconUbuntu 18.10 cosmic-security/maindeb2018.20180824.48463-1ubuntu0.12019-01-1453.2 kiB188 kiB
Ubuntu iconUbuntu 18.10 cosmic-updates/maindeb2018.20180824.48463-1ubuntu0.12019-01-1453.2 kiB188 kiB
Ubuntu iconUbuntu 19.04 disco/maindeb2018.20181218.49446-22019-03-1452.6 kiB188 kiB
Ubuntu iconUbuntu 19.10 eoan/maindeb2019.20190605.51237-2build12019-09-0652.9 kiB189 kiB
Ubuntu iconUbuntu 20.04 focal/maindeb2019.20190605.51237-3build22020-03-2453.7 kiB189 kiB

Latest updates

Ubuntu icon

Ubuntu 20.04 focal-proposed/main: Version 2019.20190605.51237-3build2 removed

2020-03-24
Ubuntu icon

Ubuntu 20.04 focal/main: Updated from 2019.20190605.51237-3build1 to 2019.20190605.51237-3build2

2020-03-24
  • No-change rebuild for icu soname change.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-66.1 to 1.21-67.2

2020-03-22
  • Use CVE numbers
Debian icon

Debian experimental experimental/main: Updated from 2020.20200313.54259-1 to 2020.20200313.54259-2

2020-03-16
Hilmar Preusse
  • Add --disable-luajithbtex for not $(LUAJIT_GOOD_ARCHS) (Closes: #953774)
Debian icon

Debian experimental experimental/main: Version 2020.20200313.54259-1 introduced

2020-03-13
Norbert Preining
  • TL 2020 source build
  • Fix FTCBFS: Add texlive-binaries <cross> to Build-Depends to have a native tangle. (Closes: #940691) (Thanks to Helmut Grohne)
  • Change BD: libfreetype6-dev -> libfreetype-dev
  • Update patches
Debian Janitor
  • Trim trailing whitespace.
  • Bump debhelper from old 9 to 12.
  • Set debhelper-compat version in Build-Depends.
  • Drop unnecessary dependency on dh-autoreconf.
  • Rely on pre-initialized dpkg-architecture variables.
Ubuntu icon

Ubuntu 20.04 focal-proposed/main: Version 2019.20190605.51237-3build2 introduced

2020-03-04
  • No-change rebuild for icu soname change.
Ubuntu icon

Ubuntu 20.04 focal-proposed/main: Version 2019.20190605.51237-3build1 removed

2020-02-27
Ubuntu icon

Ubuntu 20.04 focal/main: Updated from 2019.20190605.51237-3 to 2019.20190605.51237-3build1

2020-02-27
  • No-change rebuild for icu soname change.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-65.1 to 1.21-66.1

2020-02-25
  • Switch also to user mktex in fmtutil script (boo#1159740)
Ubuntu icon

Ubuntu 20.04 focal-proposed/main: Version 2019.20190605.51237-3build1 introduced

2020-02-13
  • No-change rebuild for icu soname change.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-64.2 to 1.21-65.1

2020-02-09
  • Check passwd not group file for user mktex
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-63.1 to 1.21-64.2

2020-01-24
  • Make patch suffix unique
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-62.1 to 1.21-63.1

2020-01-18
  • Add source-common.patch to avoid common variable (boo#1160417)
  • Ensure to have the correct version of perl-Business-ISBN and perl-Business-ISBN-Data
Ubuntu icon

Ubuntu 20.04 focal/main: Version 2019.20190605.51237-3 introduced

2020-01-07
Hilmar Preusse
  • Stop building dvisvgm package to solve FTBFS on HURD
    (Closes: #926701). It will be packaged separately (see #932968). Add the new package to Recommends.
  • Add patch to pdftex.man to document -synctex option (Closes: #772928).
  • Patch by Gero Treuner <> (mp.w_epoch.patch) MetaPost does not honour SOURCE_DATE_EPOCH (Closes: #890734).
  • Patch by John Paul Adrian Glaubitz <> (sparc64-fix-alignment.patch) to enable the alignment fixes for Linux on SPARC64 (Closes: #931873).
Norbert Preining
  • Cherry pick session:
    • lacheck: separate patterns for handling def and newcommand
    • lacheck: version bump 1.29
    • ptex: strict '! Improper alphabetic or KANJI constant.'
    • eptex: version 190709 (add ifincsname, revise iffontchar and fontchar)
    • eptex.ech: more compatible with original e-TeX
    • xdvi: don't use now-gone-from-ghostscript execute operator (from upstream) (Closes: #940191)
    • dvipdfmx: Fix a crash observed in add_ligature1_inverse_map()
    • dvipdfmx: Fix a bug that OTL coverage data were sometimes not read and were initialized to wrong values.
    • dvipdfmx: Fix evaluation of option "-m" (Closes: #926642)
    • dvipdfmx: workaround for problems in user defined resources
    • gsftopk: gs-9.28(rc1) requires -dNOSAFER
    • dvipdfmx: Take into account summertime. Always output color change code
    • dvipdfmx: show appropriate message if unsupported pfa is used
    • e-pTeX: e-pTeX 190908: readline correctly handles Japanese characters
    • ptexenc.c: updates from H. Kitagawa
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-61.1 to 1.21-62.1

2019-12-24
  • Add source-poppler0.83.0.patch: support poppler 0.83.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-60.2 to 1.21-61.1

2019-12-04
  • Apply patch 0001-Updated-tests-after-U-C-upgrade-changed-sortinit-hashes.patch also for perl 5.30.1 and up (boo#1157545)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-60.1 to 1.21-60.2

2019-11-20
  • Add patch source-fix-axohelp.patch for bsc#1155411
    • CVE-2019-18604: improper use of sprintf
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-59.2 to 1.21-60.1

2019-11-08
  • Add patch source-fix-axohelp.patch for bsc#1155411
    • CVE-2019-18604: improper use of sprintf
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-59.1 to 1.21-59.2

2019-10-05
  • Ensure that pdftoepdf-poppler-0.75.0.cc is used for any version of poppler >= 0.79.0. Fixes the build with 0.80.0.
  • Update source-poppler0.79.0.patch, since we now patch before copying.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.21-58.2 to 1.21-59.1

2019-10-02
  • Ensure that pdftoepdf-poppler-0.75.0.cc is used for any version of poppler >= 0.79.0. Fixes the build with 0.80.0.
  • Update source-poppler0.79.0.patch, since we now patch before copying.

Related packages

libsynctex2-debuginfo - Debug information for package libsynctex2
⇧ Top