Linux repositories inspector

libva-glx2 - Video Acceleration (VA) API for Linux -- GLX runtime

Video Acceleration API (VA API) is a library ("libVA") and API specification which enables and provides access to graphics hardware (GPU) acceleration for video processing on Linux and UNIX based operating systems. Accelerated processing includes video decoding, video encoding, subpicture blending and rendering. The specification was originally designed by Intel for its GMA (Graphics Media Accelerator) series of GPU hardware, the API is however not limited to GPUs or Intel specific hardware, as other hardware and manufacturers can also freely use this API for hardware accelerated video decoding.
This package provides the libva-glx library.
2.4.1
Debian iconDebian experimental
Ubuntu iconUbuntu 19.10
2.4.0
Debian iconDebian 10.0
OpenSUSE iconOpenSUSE Tumbleweed
Ubuntu iconUbuntu 19.04
2.3.0
MX Linux iconMX Linux stretch
OpenSUSE iconOpenSUSE Leap 15.1
2.2.0
Ubuntu iconUbuntu 18.10
2.1.0
Ubuntu iconUbuntu 18.04 LTS
2.0.0
OpenSUSE iconOpenSUSE Leap 15.0
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb2.4.0-1Feb 0219.8 kiB51 kiB
Debian iconDebian experimental experimental/maindeb2.4.1-1Apr 1019.8 kiB51 kiB
MX Linux iconMX Linux stretch stretch/maindeb2.3.0-2~mx17+1Jan 1419.5 kiB47 kiB
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm2.0.0-lp150.2.4Jan 1729.4 kiB22.6 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm2.3.0-lp151.1.2Jan 2330.6 kiB18.6 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm2.4.0-1.30 - 11:1425.6 kiB22.6 kiBhttps://bugs.opensuse.org
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb2.1.0-32018-06-1910.4 kiB47 kiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb2.2.0-1Jan 1410.4 kiB51 kiB
Ubuntu iconUbuntu 19.04 disco/universedeb2.4.0-1Jan 2910.2 kiB51 kiB
Ubuntu iconUbuntu 19.10 eoan/universedeb2.4.1-10 - 04:5310.2 kiB51 kiB

Latest updates

Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 2.4.1-1 reintroduced

0 - 12:13
Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 2.4.1-1 removed

0 - 10:48
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 2.4.0-1.1 to 2.4.0-1.3

0 - 11:14
  • Update to version 2.4.0:
    • va_TraceSurface support for VA_FOURCC_P010
    • Add pointer to struct wl_interface for driver to use
    • (integrate) va: fix new line symbol in error message
    • av: avoid driver path truncation
    • Fix compilation warning (uninit and wrong variable types) for Android O MR1
    • Allow import of the DRM PRIME 2 memory type
    • android: ignore unimportant compile warnnings
    • compile: fix sign/unsign compare in va_trace.c
    • android: replace utils/Log.h with log/log.h
    • High Dynamic Range Tone Mapping: Add a new filter for input metadata and some comments
    • Remove restrictions on vaSetDriverName()
Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 2.4.1-1 introduced

0 - 04:53
Debian experimental icon

Debian experimental experimental/main: Version 2.4.1-1 introduced

Apr 10
  • New upstream release.
  • debian/: Bump debhelper compat to 12.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 2.3.0-1.1 to 2.4.0-1.1

Feb 03
  • Update to version 2.4.0:
    • va_TraceSurface support for VA_FOURCC_P010
    • Add pointer to struct wl_interface for driver to use
    • (integrate) va: fix new line symbol in error message
    • av: avoid driver path truncation
    • Fix compilation warning (uninit and wrong variable types) for Android O MR1
    • Allow import of the DRM PRIME 2 memory type
    • android: ignore unimportant compile warnnings
    • compile: fix sign/unsign compare in va_trace.c
    • android: replace utils/Log.h with log/log.h
    • High Dynamic Range Tone Mapping: Add a new filter for input metadata and some comments
    • Remove restrictions on vaSetDriverName()
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.3.0-2 to 2.4.0-1

Feb 02
  • New upstream release.
  • debian/control:
    • Bump Standards-Version.
    • Add intel-media-driver to va-driver-all.
    • Set Rules-Requires-Root: no.
    • Add provides for new driver ABI.
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Updated from 2.3.0-2 to 2.4.0-1

Jan 29
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 2.4.0-1 removed

Jan 29
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 2.4.0-1 introduced

Jan 29
OpenSUSE Leap 15.1 icon

OpenSUSE Leap 15.1 oss: Version 2.3.0-lp151.1.2 introduced

Jan 23
  • Update to 2.3.0
    • Bump VA-API version to 1.3.0 and libva to 2.3.0
    • Add max frame size parameters for multiple pass case in legacy mode
    • Add new BRC mode AVBR
    • Add new interface for High Dynamic Range tone mapping
    • Add missing enum to string conversions
    • Add hevc subsets parameters structure
    • Add Customized Noise Reduction (HVS) interfaces
    • Add new BRC mode definition QVBR
    • Add more complete colour properties for use in VPP
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 oss: Version 2.0.0-lp150.2.4 introduced

Jan 17
  • Drop erroneous --disable-wayland configure call passed when building gl part.
  • Drop vaapi-wayland-tools sub-package, it does not contain any files.
  • Clean up spec, explicitly list .pc files, ensure they go into the correct devel package, stop rm'ing binaries that no longer exist.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Version 2.3.0-1.1 introduced

Jan 17
  • Update to 2.3.0
    • Bump VA-API version to 1.3.0 and libva to 2.3.0
    • Add max frame size parameters for multiple pass case in legacy mode
    • Add new BRC mode AVBR
    • Add new interface for High Dynamic Range tone mapping
    • Add missing enum to string conversions
    • Add hevc subsets parameters structure
    • Add Customized Noise Reduction (HVS) interfaces
    • Add new BRC mode definition QVBR
    • Add more complete colour properties for use in VPP
MX Linux stretch icon

MX Linux stretch stretch/main: Version 2.3.0-2~mx17+1 introduced

Jan 14
  • Rebuild for MX 17.
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Version 2.3.0-2 introduced

Jan 14
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic/universe: Version 2.2.0-1 introduced

Jan 14
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.1.0-1 to 2.3.0-2

Jan 12
  • watch: Updated.
  • control: Add Provides for new ABI version.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 2.1.0-1 to 2.1.0-3

2018-06-19
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.0.0-2 to 2.1.0-1

2018-02-26
Ondřej Nový
  • d/copyright: Use https protocol in Format field
  • d/control: Set Vcs-* to salsa.debian.org
Sebastian Ramacher
  • New upstream release.
  • debian/control:
    • Bump Standards-Version.
    • Add new driver ABI provides.
  • debian/: Bump debhelper compat to 11.
  • debian/patches: Drop patch, included upstream.
  • debian/libva2.symbols:
    • Add new symbols.
    • Bump versions of some symbols where related structs have been extended.
  • debian/copyright: Update copyright years
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 2.0.0-2 to 2.1.0-1

2018-02-26

Related packages

libva - Video Acceleration (VA) API for Linux
libva-glx2-32bit - GLX backend for the Video Acceleration API
libva-glx2-32bit-debuginfo - Debug information for package libva-glx2
libva-glx2-debuginfo - Debug information for package libva-glx2
⇧ Top