Linux repositories inspector

libvirt-dev - development files for the libvirt library

Libvirt is a C toolkit to interact with the virtualization capabilities of recent versions of Linux (and other OSes). The library aims at providing a long term stable C API for different virtualization mechanisms. It currently supports QEMU, KVM, XEN, OpenVZ, LXC, and VirtualBox.
This package contains the header files and static libraries which are needed for developing the applications with libvirt.
5.2.0
Debian iconDebian experimental
5.0.0
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
4.6.0
Ubuntu iconUbuntu 18.10
4.0.0
Ubuntu iconUbuntu 18.04 LTS
3.6.0
Ubuntu iconUbuntu 17.10
3.0.0
Debian iconDebian 9.0
1.3.1
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb5.0.0-120.01.2019185 kiB1.32 MiB
Debian iconDebian experimental experimental/maindeb5.2.0-110.04.2019189 kiB1.34 MiB
Debian iconDebian 9.0 stretch/maindeb3.0.0-4+deb9u312.01.2019171 kiB1.23 MiB
Ubuntu iconUbuntu 17.10 artful/maindeb3.6.0-1ubuntu510.11.2017138 kiB1.29 MiB
Ubuntu iconUbuntu 17.10 artful-security/maindeb3.6.0-1ubuntu6.818.06.2018138 kiB1.3 MiB
Ubuntu iconUbuntu 17.10 artful-updates/maindeb3.6.0-1ubuntu6.818.06.2018138 kiB1.3 MiB
Ubuntu iconUbuntu 18.04 LTS bionic/maindeb4.0.0-1ubuntu812.06.2018139 kiB1.31 MiB
Ubuntu iconUbuntu 18.04 LTS bionic-security/maindeb4.0.0-1ubuntu8.814.03.2019139 kiB1.31 MiB
Ubuntu iconUbuntu 18.04 LTS bionic-updates/maindeb4.0.0-1ubuntu8.814.03.2019139 kiB1.31 MiB
Ubuntu iconUbuntu 18.10 cosmic/maindeb4.6.0-2ubuntu314.01.2019142 kiB1.33 MiB
Ubuntu iconUbuntu 18.10 cosmic-security/maindeb4.6.0-2ubuntu3.414.03.2019142 kiB1.33 MiB
Ubuntu iconUbuntu 18.10 cosmic-updates/maindeb4.6.0-2ubuntu3.414.03.2019142 kiB1.33 MiB
Ubuntu iconUbuntu 19.04 disco/maindeb5.0.0-1ubuntu210.03.2019143 kiB1.35 MiB
Ubuntu iconUbuntu 16.04 LTS xenial/maindeb1.3.1-1ubuntu1010.11.2017120 kiB1.12 MiB
Ubuntu iconUbuntu 16.04 LTS xenial-security/maindeb1.3.1-1ubuntu10.2514.03.2019121 kiB1.13 MiB
Ubuntu iconUbuntu 16.04 LTS xenial-updates/maindeb1.3.1-1ubuntu10.2514.03.2019121 kiB1.13 MiB

Latest updates

Debian experimental icon

Debian experimental experimental/main: Updated from 5.1.0-1 to 5.2.0-1

10.04.2019 10:55
  • Team upload.
Christian Ehrhardt
  • [3997186] d/libvirt-daemon-system.maintscript: remove obsolete conffile /etc/logrotate.d/libvirtd.uml became obsolete since UML was dropped in libvirt 5.0 (Closes: #920574)
  • [c64d020] d/libvirt-daemon-system.libvirtd.default: clarify libvirtd_opts example (Closes: #921713)
Guido Günther
  • [dd9d74f] New upstream version 5.2.0
  • [790365e] CVE-2019-3886: Don't allow unprivileged users to use the guest agent. Apply upstream patches remote-enforce-ACL-write-permission-for-getting-guest-tim.patch api-disallow-virDomainGetHostname-for-read-only-connectio.patch (Closes: #926418)
Andrea Bolognani
  • [453f85d] Rediff patches. The patches security-aa-helper-allow-virt-aa-helper-to-read-dev-dri.patch security-aa-helper-generate-more-rules-for-gl-devices.patch security-aa-helper-gl-devices-in-sysfs-at-arbitrary-depth.patch security-aa-helper-nvidia-rules-for-gl-devices.patch virt-aa-helper-generate-rules-for-gl-enabled-graphics-dev.patch are included in libvirt 5.2.0 and have thus been dropped.
  • [a4294ef] Bump symbol versions.
  • [68394f6] Add tests-Avoid-writing-into-HOME-during-virsh-snapshot.patch
Debian experimental icon

Debian experimental experimental/main: Version 5.1.0-1 introduced

28.03.2019 17:30
Laurent Bigonville
  • [76e2cb7] Don't recommend ebtables.
    It's part of the iptables package now. (Closes: #918472)
Guido Günther
  • [5814c89] New upstream version 5.1.0
  • [55d063d] Rediff patches
  • [1102dae] d/gbp.conf: Switch to experimental
  • [cdf3787] d/rules: Adjust to now versioned wireshark module path
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-updates/main: Updated from 4.0.0-1ubuntu8.7 to 4.0.0-1ubuntu8.8

14.03.2019 15:55
See package libvirt0
Ubuntu 16.04 LTS icon

Ubuntu 16.04 LTS xenial-updates/main: Updated from 1.3.1-1ubuntu10.24 to 1.3.1-1ubuntu10.25

14.03.2019 15:50
See package libvirt0
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-updates/main: Updated from 4.6.0-2ubuntu3.3 to 4.6.0-2ubuntu3.4

14.03.2019 15:40
See package libvirt0
Ubuntu 16.04 LTS icon

Ubuntu 16.04 LTS xenial-security/main: Updated from 1.3.1-1ubuntu10.24 to 1.3.1-1ubuntu10.25

14.03.2019 15:30
See package libvirt0
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-security/main: Updated from 4.0.0-1ubuntu8.2 to 4.0.0-1ubuntu8.8

14.03.2019 15:25
See package libvirt0
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-security/main: Version 4.6.0-2ubuntu3.4 introduced

14.03.2019 14:50
See package libvirt0
Ubuntu 19.04 icon

Ubuntu 19.04 disco/main: Updated from 5.0.0-1ubuntu1 to 5.0.0-1ubuntu2

10.03.2019 08:44
See package libvirt0
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-updates/main: Updated from 4.6.0-2ubuntu3.2 to 4.6.0-2ubuntu3.3

10.03.2019 08:44
See package libvirt0
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-proposed/main: Version 4.6.0-2ubuntu3.3 removed

10.03.2019 08:43
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-updates/main: Updated from 4.0.0-1ubuntu8.6 to 4.0.0-1ubuntu8.7

10.03.2019 08:43
See package libvirt0
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/main: Version 4.0.0-1ubuntu8.7 removed

10.03.2019 08:42
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/main: Version 4.0.0-1ubuntu8.7 introduced

27.02.2019 20:05
See package libvirt0
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-proposed/main: Version 4.6.0-2ubuntu3.3 introduced

27.02.2019 19:25
See package libvirt0
Ubuntu 19.04 icon

Ubuntu 19.04 disco/main: Updated from 4.6.0-2ubuntu5 to 5.0.0-1ubuntu1

27.01.2019 17:15
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/main: Version 5.0.0-1ubuntu1 removed

27.01.2019 15:05
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/main: Version 4.6.0-2ubuntu6 removed

25.01.2019 13:50
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/main: Version 5.0.0-1ubuntu1 reintroduced

25.01.2019 13:50
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/main: Version 5.0.0-1ubuntu1 removed

25.01.2019 12:35

Related packages

libvirt - API for controlling virtualization engines (openvz,kvm,qemu,virtualbox,xen,etc)
⇧ Top