Linux repositories inspector

libvirt-sanlock - Sanlock plugin for virtlockd

Libvirt is a C toolkit to interact with the virtualization capabilities of recent versions of Linux (and other OSes). The library aims at providing a long term stable C API for different virtualization mechanisms. It currently supports QEMU, KVM, XEN, OpenVZ, LXC, and VirtualBox.
This package contains the sanlock plugin for libvirt's locking daemon.
6.0.0
Ubuntu iconUbuntu 20.04
5.4.0
Ubuntu iconUbuntu 19.10
5.0.0
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
4.6.0
Ubuntu iconUbuntu 18.10
4.0.0
Ubuntu iconUbuntu 18.04 LTS
3.6.0
Ubuntu iconUbuntu 17.10
3.0.0
Debian iconDebian 9.0
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb5.0.0-4+deb10u1Feb 08109 kiB213 kiB
Debian iconDebian 9.0 stretch/maindeb3.0.0-4+deb9u4Sep 0777.8 kiB148 kiB
Ubuntu iconUbuntu 17.10 artful/universedeb3.6.0-1ubuntu52017-11-1041.9 kiB203 kiB
Ubuntu iconUbuntu 17.10 artful-security/universedeb3.6.0-1ubuntu6.82018-06-1841.8 kiB204 kiB
Ubuntu iconUbuntu 17.10 artful-updates/universedeb3.6.0-1ubuntu6.82018-06-1841.8 kiB204 kiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb4.0.0-1ubuntu82018-06-1942.7 kiB208 kiB
Ubuntu iconUbuntu 18.04 LTS bionic-security/universedeb4.0.0-1ubuntu8.122019-07-0842.7 kiB210 kiB
Ubuntu iconUbuntu 18.04 LTS bionic-updates/universedeb4.0.0-1ubuntu8.15Mar 1942.8 kiB210 kiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb4.6.0-2ubuntu32019-01-1433 kiB192 kiB
Ubuntu iconUbuntu 18.10 cosmic-security/universedeb4.6.0-2ubuntu3.82019-07-0833.1 kiB193 kiB
Ubuntu iconUbuntu 18.10 cosmic-updates/universedeb4.6.0-2ubuntu3.82019-07-0833.1 kiB193 kiB
Ubuntu iconUbuntu 19.04 disco/universedeb5.0.0-1ubuntu22019-03-1066.9 kiB270 kiB
Ubuntu iconUbuntu 19.04 disco-security/universedeb5.0.0-1ubuntu2.42019-07-0867 kiB271 kiB
Ubuntu iconUbuntu 19.04 disco-updates/universedeb5.0.0-1ubuntu2.6Dec 0267 kiB271 kiB
Ubuntu iconUbuntu 19.10 eoan/universedeb5.4.0-0ubuntu5Sep 0668.2 kiB283 kiB
Ubuntu iconUbuntu 19.10 eoan-proposed/universedeb5.4.0-0ubuntu5.2Mar 2468.3 kiB283 kiB
Ubuntu iconUbuntu 19.10 eoan-updates/universedeb5.4.0-0ubuntu5.1Mar 1968.3 kiB283 kiB
Ubuntu iconUbuntu 20.04 focal/universedeb6.0.0-0ubuntu5Mar 1325.6 kiB198 kiB

Latest updates

Ubuntu icon

Ubuntu 19.10 eoan-proposed/universe: Version 5.4.0-0ubuntu5.2 introduced

Mar 24
Ubuntu icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 4.0.0-1ubuntu8.15 removed

Mar 19
Ubuntu icon

Ubuntu 19.10 eoan-proposed/universe: Version 5.4.0-0ubuntu5.1 removed

Mar 19
Ubuntu icon

Ubuntu 18.04 LTS bionic-updates/universe: Updated from 4.0.0-1ubuntu8.14 to 4.0.0-1ubuntu8.15

Mar 19
Ubuntu icon

Ubuntu 19.10 eoan-updates/universe: Version 5.4.0-0ubuntu5.1 introduced

Mar 19
Debian icon

Debian experimental experimental/main: Version 6.0.0-1 removed

Mar 15
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 6.0.0-0ubuntu4 to 6.0.0-0ubuntu5

Mar 13
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 6.0.0-0ubuntu5 removed

Mar 13
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 6.0.0-0ubuntu5 introduced

Mar 13
Ubuntu icon

Ubuntu 19.10 eoan-proposed/universe: Version 5.4.0-0ubuntu5.1 introduced

Mar 05
Ubuntu icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 4.0.0-1ubuntu8.15 introduced

Mar 05
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 6.0.0-0ubuntu3 to 6.0.0-0ubuntu4

Mar 02
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 6.0.0-0ubuntu3 removed

Feb 14
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 6.0.0-0ubuntu2 to 6.0.0-0ubuntu3

Feb 14
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 6.0.0-0ubuntu3 introduced

Feb 14
Debian icon

Debian experimental experimental/main: Updated from 5.6.0-4 to 6.0.0-1

Feb 13
Guido Günther
  • [33890b9] New upstream version 6.0.0
    (Closes: #939552)
  • [c9f82be] gitlab-ci: Run autopkgtests
Christian Ehrhardt
  • [fa167bc] d/libnss-libvirt.lintian-overrides: accept having two nss so files
  • [bf48357] d/libvirt-daemon-system-sysv.lintian-overrides: not shipping systemd files. Packages are split intentionally, ignore this lintian warning.
  • [2278598] d/rules: also check build time self test results on all architectures
  • [c1be36a] d/rules: drop doc binary cleanup.
  • [6d60c3c] d/rules: don't ship split daemons just yet
  • [33f8dc4] d/p/skip-qemuhotplugtest.patch: fix qemuhotplugtest. Skip some elements of qemuhotplugtest that for now break in Debian/Ubuntu build environments.
  • [a1734f7] d/rules: add libvirt-guests.default to libvirt-daemon-system instead of libvirt-daemon-system-sysv
  • [69f6cfe] d/rules: install /etc/default/* files that are shared between sysv and systemd packages
  • [31be682] d/rules: install virtlockd for sysv
    (Closes: #880970)
Andrea Bolognani
  • [070d158] Install virt-login-shell-helper.
    This new binary was introduced in libvirt 5.7.0 and is necessary for virt-login-shell to work.
  • [143dafb] Install augeas lenses for all drivers.
    These slipped through the cracks when we moved from picking up the corresponding directories as a whole to listing the specific files we're interested in.
  • [efa4cfe] Remove all mentions of Devhelp.
    As of libvirt 5.8.0, the corresponding files are no longer generated.
  • [8ebd427] not-installed: Remove obsolete entries.
    Now that upstream's build system has been fixed and we're picking up the documentation from the install location rather than the source directory, the corresponding files will no longer be flagged by dh_missing.
  • [ce54aef] not-installed: List all split daemons files. Since we're not shipping split daemons yet, the corresponding binaries as well as systemd units and augeas lenses will be flagged by dh_missing if we don't list them here.
  • [391e39d] symbols: Drop LIBVIRT_5.9.0
    libvirt 5.9.0 didn't introduce any new public symbols.
Debian icon

Debian 10.0 buster-proposed-updates/main: Version 5.0.0-4+deb10u1 removed

Feb 08
Debian icon

Debian 10.0 buster/main: Updated from 5.0.0-4 to 5.0.0-4+deb10u1

Feb 08
Tobias Wolter
  • [711f612] apparmor: Allow one to run pygrub
Guido Günther
  • [3bcbf56] Don't render osxsave, ospke into QEMU comman line. This helps newer QEMU with some configs generated by virt-install. Thanks to Michal Arbet for digging out the patches (Closes: #944248)
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 6.0.0-0ubuntu2 removed

Feb 06
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 6.0.0-0ubuntu1 to 6.0.0-0ubuntu2

Feb 06

Related packages

libvirt - API for controlling virtualization engines (openvz,kvm,qemu,virtualbox,xen,etc)
sanlock - A shared storage lock manager
⇧ Top