Linux repositories inspector

libvncserver-devel - Development files for libvncserver

VNC is a set of programs using the RFB (Remote Frame Buffer) protocol. They are designed to "export" a frame buffer via the network. It is already in wide use for administration, but it is not that easy to program a server yourself. This has been changed by LibVNCServer.
X.org already has a virtual Xvnc server which you can start as an own screen (e.g. :1) and connect to with a VNC client (e.g. vncviewer from tightvnc).

The LibVNCServer-devel package contains the static libraries and header files for LibVNCServer.
0.9.12
Fedora iconFedora rawhide
OpenSUSE iconOpenSUSE Tumbleweed
0.9.11
Fedora iconFedora 28
Fedora iconFedora 29
Fedora iconFedora 30
Fedora iconFedora 31
0.9.10
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 15.1
OpenSUSE iconOpenSUSE Leap 15.2
0.9.9
CentOS iconCentOS 7.7.1908
OpenSUSE iconOpenSUSE Leap 42.3
DistributionVersionSincePackageInstalledPackager
CentOS iconCentOS 7.7.1908 osrpm0.9.9-13.el7_62020-01-0756.3 kiB211 kiBCentOS BuildSystem
CentOS iconCentOS 7.7.1908 updatesrpm0.9.9-14.el7_72020-03-2456.5 kiB211 kiBCentOS BuildSystem
Fedora iconFedora 28 releases/Everything-osrpm0.9.11-6.fc282019-01-1459.5 kiB208 kiBFedora Project
Fedora iconFedora 29 releases/Everything-osrpm0.9.11-8.fc292019-01-1456.9 kiB209 kiBFedora Project
Fedora iconFedora 29 releases-test/Everything-osrpm0.9.11-8.fc292019-01-1456.9 kiB209 kiBFedora Project
Fedora iconFedora 30 releases/Everything-osrpm0.9.11-9.fc302019-06-1757 kiB209 kiBFedora Project
Fedora iconFedora 31 releases/Everything-osrpm0.9.11-10.fc312020-01-0755.8 kiB209 kiBFedora Project
Fedora iconFedora rawhide development/Everything-osrpm0.9.12-1.fc332020-02-1954.8 kiB205 kiBFedora Project
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm0.9.10-lp150.2.32019-01-17138 kiB592 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm0.9.10-lp150.3.6.12019-02-18140 kiB592 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm0.9.10-lp150.3.3.12019-01-18139 kiB592 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm0.9.10-lp150.3.10.12019-03-28140 kiB592 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm0.9.10-lp151.6.12019-04-02135 kiB592 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.2 ossrpm0.9.10-lp152.7.52020-01-17135 kiB592 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 ossrpm0.9.9-15.42019-01-17123 kiB551 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm0.9.9-16.9.12019-02-19124 kiB551 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm0.9.9-16.6.12019-01-21124 kiB551 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm0.9.9-16.3.12019-01-21123 kiB551 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm0.9.9-16.12.12019-03-28124 kiB551 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm0.9.12-3.12020-01-14156 kiB646 kiBhttps://bugs.opensuse.org

Latest updates

CentOS icon

CentOS 7.7.1908 updates: Version 0.9.9-14.el7_7 introduced

2020-03-24
  • Fix CVE-2019-15690 (an integer overflow in HandleCursorShape() in a client) (bug #1814339)
Fedora icon

Fedora rawhide development/Everything-os: Updated from 0.9.11-11.fc32 to 0.9.12-1.fc33

2020-02-19
  • Update to 0.9.12
Fedora icon

Fedora rawhide development/Everything-os: Updated from 0.9.11-10.fc31 to 0.9.11-11.fc32

2020-02-08
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 0.9.10-lp152.7.4 to 0.9.10-lp152.7.5

2020-01-17
  • Add BuildRequire libgnutls-devel: Remmina needs it for VNC connections (boo#1123805)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 0.9.12-2.2 to 0.9.12-3.1

2020-01-14
  • Add patches to fix crash on shutdown:
    • avoid-pthread_join-if-backgroundLoop-is-FALSE.patch
    • fix-crash-on-shutdown.patch
Fedora icon

Fedora 31 releases/Everything-os: Version 0.9.11-10.fc31 introduced

2020-01-07
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Version 0.9.10-lp152.7.4 introduced

2020-01-07
  • Add BuildRequire libgnutls-devel: Remmina needs it for VNC connections (boo#1123805)
CentOS icon

CentOS 7.7.1908 os: Version 0.9.9-13.el7_6 introduced

2020-01-07
  • Fix CVE-2018-15127 (Heap out-of-bounds write in
    rfbserver.c:rfbProcessFileTransferReadBuffer()) (bug #1662995)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 0.9.12-2.1 to 0.9.12-2.2

2019-11-18
  • turn the test suite on
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 0.9.12-1.4 to 0.9.12-2.1

2019-11-12
  • turn the test suite on
Fedora icon

Fedora rawhide development/Everything-os: Updated from 0.9.11-9.fc30 to 0.9.11-10.fc31

2019-08-03
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 0.9.12-1.3 to 0.9.12-1.4

2019-07-16
  • Add BuildRequire libgnutls-devel: Remmina needs it for VNC connections (boo#1123805)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 0.9.12-1.1 to 0.9.12-1.3

2019-06-17
  • Add BuildRequire libgnutls-devel: Remmina needs it for VNC connections (boo#1123805)
Fedora icon

Fedora 30 releases/Everything-os: Version 0.9.11-9.fc30 introduced

2019-06-17
OpenSUSE icon

OpenSUSE Leap 15.1 oss: Updated from 0.9.10-lp151.5.1 to 0.9.10-lp151.6.1

2019-04-02
  • Add BuildRequire libgnutls-devel: Remmina needs it for VNC connections (boo#1123805)
OpenSUSE icon

OpenSUSE Leap 42.3 update/oss: Updated from 0.9.9-16.9.1 to 0.9.9-16.12.1

2019-03-28
  • Add BuildRequire libgnutls-devel: Remmina needs it for VNC connections (boo#1123805)
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Updated from 0.9.10-lp150.3.6.1 to 0.9.10-lp150.3.10.1

2019-03-28
  • Add BuildRequire libgnutls-devel: Remmina needs it for VNC connections (boo#1123805)
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 0.9.10-lp150.3.6.1 reintroduced

2019-03-23
  • security update
    • CVE-2018-20749 [bsc#1123828]
      • LibVNCServer-CVE-2018-20749.patch
    • CVE-2018-20750 [bsc#1123832]
      • LibVNCServer-CVE-2018-20750.patch
    • CVE-2018-20748 [bsc#1123823]
      • LibVNCServer-CVE-2018-20748.patch
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 0.9.10-lp150.3.3.1 reintroduced

2019-03-23
  • security update
    • CVE-2018-15126 [bsc#1120114]
      • LibVNCServer-CVE-2018-15126.patch
    • CVE-2018-6307 [bsc#1120115]
      • LibVNCServer-CVE-2018-6307.patch
    • CVE-2018-20020 [bsc#1120116]
      • LibVNCServer-CVE-2018-20020.patch
    • CVE-2018-15127 [bsc#1120117]
      • LibVNCServer-CVE-2018-15127.patch
    • CVE-2018-20019 [bsc#1120118]
      • LibVNCServer-CVE-2018-20019.patch
    • CVE-2018-20023 [bsc#1120119]
      • LibVNCServer-CVE-2018-20023.patch
    • CVE-2018-20022 [bsc#1120120]
      • LibVNCServer-CVE-2018-20022.patch
    • CVE-2018-20024 [bsc#1120121]
      • LibVNCServer-CVE-2018-20024.patch
    • CVE-2018-20021 [bsc#1120122]
      • LibVNCServer-CVE-2018-20021.patch
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 0.9.10-lp150.3.6.1 removed

2019-03-22

Related packages

libvncserver - Cross-platform C libraries that allow you to easily implement VNC server or client functionality
devel - Hydrogen header files
⇧ Top