Linux repositories inspector

libwscodecs1 - network packet dissection codecs library -- shared library

The libwscodecs library provides codec functions for libwireshark10.
Original maintainer
Homepagehttps://www.wireshark.org/
2.4.11
OpenSUSE iconOpenSUSE Leap 15.0
2.4.10
OpenSUSE iconOpenSUSE Leap 15.0
2.4.9
OpenSUSE iconOpenSUSE Leap 15.0
2.4.8
OpenSUSE iconOpenSUSE Leap 15.0
2.4.7
OpenSUSE iconOpenSUSE Leap 15.0
2.4.6
OpenSUSE iconOpenSUSE Leap 15.0
2.4.5
Ubuntu iconUbuntu 18.04 LTS
2.4.2
Ubuntu iconUbuntu 17.10
2.2.6
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm2.4.6-lp150.1.1417.01.2019128 kiB27.3 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm2.4.9-lp150.2.10.118.01.2019130 kiB27.3 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm2.4.8-lp150.2.6.118.01.2019129 kiB27.3 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm2.4.7-lp150.2.3.118.01.2019128 kiB27.3 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm2.4.11-lp150.2.16.118.01.2019131 kiB27.3 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm2.4.10-lp150.2.13.118.01.2019130 kiB27.3 kiBhttp://bugs.opensuse.org
Ubuntu iconUbuntu 17.10 artful/universedeb2.4.2-110.11.201716.2 kiB83 kiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb2.4.5-107.03.201816.2 kiB84 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-security/universedeb2.2.6+g32dac6a-2ubuntu0.16.0410.11.201716.4 kiB88 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-updates/universedeb2.2.6+g32dac6a-2ubuntu0.16.0410.11.201716.4 kiB88 kiB

Latest updates

OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Updated from 2.4.10-lp150.2.13.1 to 2.4.11-lp150.2.16.1

18.01.2019 02:45
  • Wireshark 2.4.11 (bsc#1117740):
    • CVE-2018-19625: The Wireshark dissection engine could crash (wnpa-sec-2018-51)
    • CVE-2018-19626: The DCOM dissector could crash (wnpa-sec-2018-52)
    • CVE-2018-19623: The LBMPDM dissector could crash (wnpa-sec-2018-53)
    • CVE-2018-19622: The MMSE dissector could go into an infinite loop (wnpa-sec-2018-54)
    • CVE-2018-19627: The IxVeriWave file parser could crash (wnpa-sec-2018-55)
    • CVE-2018-19624: The PVFS dissector could crash (wnpa-sec-2018-56)
  • Further bug fixes and updated protocol support as listed in: https://www.wireshark.org/docs/relnotes/wireshark-2.4.11.html
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 2.4.10-lp150.2.13.1 introduced

18.01.2019 02:45
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 oss: Version 2.4.6-lp150.1.14 introduced

17.01.2019 18:51
  • Wireshark 2.4.6:
    This release fixes minor vulnerabilities that could be used to trigger dissector crashes or cause dissectors to go into large infinite loops by making Wireshark read specially crafted packages from the network or capture files (bsc#1088200):
    • CVE-2018-9264: ADB dissector crash
    • CVE-2018-9260: IEEE 802.15.4 dissector crash
    • CVE-2018-9261: NBAP dissector crash
    • CVE-2018-9262: VLAN dissector crash
    • CVE-2018-9256: LWAPP dissector crash
    • CVE-2018-9263: Kerberos dissector crash
    • CVE-2018-9258: TCP dissector crash
    • CVE-2018-9257: CQL infinite loop
    • Memory leaks in multiple dissectors:
      CVE-2018-9265, CVE-2018-9266, CVE-2018-9267, CVE-2018-9268, CVE-2018-9269, CVE-2018-9270, CVE-2018-9271, CVE-2018-9272, CVE-2018-9273, CVE-2018-9274
    • Further bug fixes and updated protocol support as listed in: https://www.wireshark.org/docs/relnotes/wireshark-2.4.6.html
Debian 10.0 icon

Debian 10.0 buster/main: Version 2.4.5-1 removed

12.01.2019 14:16
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 2.2.6+g32dac6a-2+deb9u3 removed

12.01.2019 13:52
Debian 9.0 icon

Debian 9.0 stretch/main: Version 2.2.6+g32dac6a-2+deb9u2 removed

12.01.2019 13:50
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 2.2.6+g32dac6a-2+deb9u3 introduced

19.06.2018 07:50
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 2.2.6+g32dac6a-2+deb9u2 removed

14.03.2018 02:47
Debian 9.0 icon

Debian 9.0 stretch/main: Updated from 2.2.6+g32dac6a-2 to 2.2.6+g32dac6a-2+deb9u2

14.03.2018 02:46
  • Non-maintainer upload by the Wheezy LTS Team.
  • fix for CVE-2018-5334
  • fix for CVE-2018-5335
  • fix for CVE-2018-5336
    Several parsers of wireshark could be crashed by malformed packets.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.4.4-1 to 2.4.5-1

07.03.2018 04:29
  • New upstream release
    • release notes:
      https://www.wireshark.org/docs/relnotes/wireshark-2.4.5.html
    • security fixes:
      • The SIGCOMP dissector could crash (CVE-2018-7320, CVE-2018-7418)
      • Multiple dissectors could go into large infinite loops. All ASN.1 BER dissectors, along with the DICOM, DMP, LLTD, OpenFlow, RELOAD, RPCoRDMA, RPKI-Router, S7COMM, SCCP, Thread, Thrift, USB, and WCCP dissectors were susceptible. (CVE-2018-7321, CVE-2018-7322, CVE-2018-7323, CVE-2018-7324, CVE-2018-7325, CVE-2018-7326, CVE-2018-7327, CVE-2018-7328, CVE-2018-7329, CVE-2018-7330, CVE-2018-7331, CVE-2018-7332, CVE-2018-7333)
      • The UMTS MAC dissector could crash (CVE-2018-7334)
      • The IEEE 802.11 dissector could crash (CVE-2018-7335)
      • The FCP dissector could crash (CVE-2018-7336)
      • The DOCSIS dissector could crash (CVE-2018-7337)
      • The IPMI dissector could crash (CVE-2018-7417)
      • The NBAP disssector could crash (CVE-2018-7419)
      • The pcapng file parser could crash (CVE-2018-7420)
    • Only recommend libjs-openlayers (Closes: #888744)
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 2.4.4-1 to 2.4.5-1

07.03.2018 04:24
See package libwsutil8
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Updated from 2.2.6+g32dac6a-2+deb9u1 to 2.2.6+g32dac6a-2+deb9u2

26.02.2018 04:22
  • Non-maintainer upload by the Wheezy LTS Team.
  • fix for CVE-2018-5334
  • fix for CVE-2018-5335
  • fix for CVE-2018-5336
    Several parsers of wireshark could be crashed by malformed packets.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 2.4.3-1 to 2.4.4-1

28.01.2018 00:06
See package libwsutil8
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 2.4.4-1 removed

27.01.2018 23:40
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.4.3-1 to 2.4.4-1

23.01.2018 04:07
  • New upstream release
    • release notes:
      https://www.wireshark.org/docs/relnotes/wireshark-2.4.4.html
    • security fixes:
      • Multiple dissectors could crash (CVE-2018-5336)
      • The IxVeriWave file parser could crash (CVE-2018-5334)
      • The WCP dissector could crash (CVE-2018-5335)
      • Prior to this release dumpcap enabled the Linux kernel’s BPF JIT compiler via the net.core.bpf_jit_enable sysctl. This could make systems more vulnerable to Spectre variant 1 (CVE-2017-5753) and this feature has been removed (Closes: #886619)
      • There was a potential buffer underflow in File_read_line function in epan/wslua/wslua_file.c file (CVE-2017-17935) (Closes: #885831)
    • Update symbols files
    • Fix dh_clean target in debian/rules
    • Change wireshark-doc's priority to optional from extra following Policy change
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 2.4.4-1 introduced

14.01.2018 03:20
See package libwsutil8
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 2.2.6+g32dac6a-2+deb9u1 introduced

24.12.2017 11:20
  • CVE-2017-11408 / CVE-2017-13766 / CVE-2017-17083.patch / CVE-2017-17084.patch CVE-2017-17085
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.4.2-1 to 2.4.3-1

09.12.2017 22:54
  • Show version info instead of just "Git Rev Unknown from unknown"
  • New upstream release
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 2.4.2-1 to 2.4.3-1

05.12.2017 07:01
See package libwsutil8
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 2.4.3-1 removed

05.12.2017 06:35
⇧ Top