Linux repositories inspector

libwsutil-dev - network packet dissection utilities library -- development files

The libwsutil library provides utility functions for libwireshark6.
This package contains the static library and the C header files that are needed for applications to use the libwsutil library.
Original maintainer
Homepagehttp://www.wireshark.org/
2.6.6
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
2.6.5
Debian iconDebian 9.0
Ubuntu iconUbuntu 18.04 LTS
Ubuntu iconUbuntu 18.10
Ubuntu iconUbuntu 16.04 LTS
2.6.4
Ubuntu iconUbuntu 18.10
2.6.3
Debian iconDebian 9.0
2.4.5
Ubuntu iconUbuntu 18.04 LTS
2.4.2
Ubuntu iconUbuntu 17.10
2.0.2
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb2.6.6-112.01.201988.3 kiB256 kiB
Debian iconDebian 9.0 stretch/maindeb2.6.3-1~deb9u112.01.201990.6 kiB256 kiB
Debian iconDebian 9.0 stretch-proposed-updates/maindeb2.6.5-1~deb9u112.01.201994.6 kiB263 kiB
Ubuntu iconUbuntu 17.10 artful/universedeb2.4.2-110.11.201736 kiB263 kiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb2.4.5-107.03.201836 kiB264 kiB
Ubuntu iconUbuntu 18.04 LTS bionic-security/universedeb2.6.5-1~ubuntu18.04.012.01.201941 kiB243 kiB
Ubuntu iconUbuntu 18.04 LTS bionic-updates/universedeb2.6.5-1~ubuntu18.04.012.01.201941 kiB243 kiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb2.6.4-114.01.201940.9 kiB241 kiB
Ubuntu iconUbuntu 18.10 cosmic-security/universedeb2.6.5-1~ubuntu18.10.014.01.201941 kiB243 kiB
Ubuntu iconUbuntu 18.10 cosmic-updates/universedeb2.6.5-1~ubuntu18.10.014.01.201941 kiB243 kiB
Ubuntu iconUbuntu 19.04 disco/universedeb2.6.6-114.01.201941.1 kiB243 kiB
Ubuntu iconUbuntu 16.04 LTS xenial/universedeb2.0.2+ga16e22e-110.11.201733.6 kiB250 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-security/universedeb2.6.5-1~ubuntu16.04.012.01.201941.1 kiB243 kiB
Ubuntu iconUbuntu 16.04 LTS xenial-updates/universedeb2.6.5-1~ubuntu16.04.012.01.201941.1 kiB243 kiB

Latest updates

Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Version 2.6.6-1 introduced

14.01.2019 13:07
See package libwsutil9
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-updates/universe: Version 2.6.5-1~ubuntu18.10.0 introduced

14.01.2019 03:16
See package libwsutil9
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic-security/universe: Version 2.6.5-1~ubuntu18.10.0 introduced

14.01.2019 03:15
See package libwsutil9
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic/universe: Version 2.6.4-1 introduced

14.01.2019 03:12
See package libwsutil9
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.4.5-1 to 2.6.6-1

12.01.2019 14:14
Jean-Philippe MENGUAL
  • French debconf translation update (Closes: #915161)
Balint Reczey
  • New upstream version 2.6.6
    • security fixes:
      • The P_MUL dissector could crash. (CVE-2019-5717)
      • The RTSE dissector and other dissectors could crash. (CVE-2019-5718)
      • The ISAKMP dissector could crash. (CVE-2019-5719)
      • The 6LoWPAN dissector could crash. (CVE-2019-5716)
    • Mention GPLv3+ code snippet in tools/pidl/idl.yp (Closes: #918089)
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Updated from 2.2.6+g32dac6a-2+deb9u3 to 2.6.5-1~deb9u1

12.01.2019 13:52
  • Rebuild for Stretch
Debian 9.0 icon

Debian 9.0 stretch/main: Updated from 2.2.6+g32dac6a-2+deb9u2 to 2.6.3-1~deb9u1

12.01.2019 13:50
  • Rebuild for stretch
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-updates/universe: Version 2.6.5-1~ubuntu18.04.0 introduced

12.01.2019 13:45
See package libwsutil9
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-security/universe: Version 2.6.5-1~ubuntu18.04.0 introduced

12.01.2019 13:44
See package libwsutil9
Ubuntu 16.04 LTS icon

Ubuntu 16.04 LTS xenial-updates/universe: Updated from 2.2.6+g32dac6a-2ubuntu0.16.04 to 2.6.5-1~ubuntu16.04.0

12.01.2019 13:42
See package libwsutil9
Ubuntu 16.04 LTS icon

Ubuntu 16.04 LTS xenial-security/universe: Updated from 2.2.6+g32dac6a-2ubuntu0.16.04 to 2.6.5-1~ubuntu16.04.0

12.01.2019 13:41
See package libwsutil9
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 2.2.6+g32dac6a-2+deb9u3 introduced

19.06.2018 07:50
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 2.2.6+g32dac6a-2+deb9u2 removed

14.03.2018 02:47
Debian 9.0 icon

Debian 9.0 stretch/main: Updated from 2.2.6+g32dac6a-2 to 2.2.6+g32dac6a-2+deb9u2

14.03.2018 02:46
  • Non-maintainer upload by the Wheezy LTS Team.
  • fix for CVE-2018-5334
  • fix for CVE-2018-5335
  • fix for CVE-2018-5336
    Several parsers of wireshark could be crashed by malformed packets.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.4.4-1 to 2.4.5-1

07.03.2018 04:29
  • New upstream release
    • release notes:
      https://www.wireshark.org/docs/relnotes/wireshark-2.4.5.html
    • security fixes:
      • The SIGCOMP dissector could crash (CVE-2018-7320, CVE-2018-7418)
      • Multiple dissectors could go into large infinite loops. All ASN.1 BER dissectors, along with the DICOM, DMP, LLTD, OpenFlow, RELOAD, RPCoRDMA, RPKI-Router, S7COMM, SCCP, Thread, Thrift, USB, and WCCP dissectors were susceptible. (CVE-2018-7321, CVE-2018-7322, CVE-2018-7323, CVE-2018-7324, CVE-2018-7325, CVE-2018-7326, CVE-2018-7327, CVE-2018-7328, CVE-2018-7329, CVE-2018-7330, CVE-2018-7331, CVE-2018-7332, CVE-2018-7333)
      • The UMTS MAC dissector could crash (CVE-2018-7334)
      • The IEEE 802.11 dissector could crash (CVE-2018-7335)
      • The FCP dissector could crash (CVE-2018-7336)
      • The DOCSIS dissector could crash (CVE-2018-7337)
      • The IPMI dissector could crash (CVE-2018-7417)
      • The NBAP disssector could crash (CVE-2018-7419)
      • The pcapng file parser could crash (CVE-2018-7420)
    • Only recommend libjs-openlayers (Closes: #888744)
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 2.4.4-1 to 2.4.5-1

07.03.2018 04:24
See package libwsutil8
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Updated from 2.2.6+g32dac6a-2+deb9u1 to 2.2.6+g32dac6a-2+deb9u2

26.02.2018 04:22
  • Non-maintainer upload by the Wheezy LTS Team.
  • fix for CVE-2018-5334
  • fix for CVE-2018-5335
  • fix for CVE-2018-5336
    Several parsers of wireshark could be crashed by malformed packets.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 2.4.3-1 to 2.4.4-1

28.01.2018 00:06
See package libwsutil8
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 2.4.4-1 removed

27.01.2018 23:40
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 2.4.3-1 to 2.4.4-1

23.01.2018 04:07
  • New upstream release
    • release notes:
      https://www.wireshark.org/docs/relnotes/wireshark-2.4.4.html
    • security fixes:
      • Multiple dissectors could crash (CVE-2018-5336)
      • The IxVeriWave file parser could crash (CVE-2018-5334)
      • The WCP dissector could crash (CVE-2018-5335)
      • Prior to this release dumpcap enabled the Linux kernel’s BPF JIT compiler via the net.core.bpf_jit_enable sysctl. This could make systems more vulnerable to Spectre variant 1 (CVE-2017-5753) and this feature has been removed (Closes: #886619)
      • There was a potential buffer underflow in File_read_line function in epan/wslua/wslua_file.c file (CVE-2017-17935) (Closes: #885831)
    • Update symbols files
    • Fix dh_clean target in debian/rules
    • Change wireshark-doc's priority to optional from extra following Policy change
⇧ Top