Linux repositories inspector

libxerces-c3.1 - validating XML parser library for C++

Xerces-C++ is a validating XML parser written in a portable subset of C++. Xerces-C++ makes it easy to give your application the ability to read and write XML data. A shared library is provided for parsing, generating, manipulating, and validating XML documents. Xerces-C++ is faithful to the XML 1.0 recommendation and associated standards (DOM 1.0, DOM 2.0, SAX 1.0, SAX 2.0, Namespaces, XML Schema Part 1 and Part 2). It also provides experimental implementations of XML 1.1 and DOM Level 3.0. The parser provides high performance, modularity, and scalability.
3.1.4
Debian iconDebian 9.0
Ubuntu iconUbuntu 17.10
3.1.3
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 9.0 stretch/maindeb3.1.4+debian-2+deb9u1Jan 12822 kiB3.57 MiB
Ubuntu iconUbuntu 17.10 artful/universedeb3.1.4+debian-22017-11-10819 kiB3.47 MiB
Ubuntu iconUbuntu 16.04 LTS xenial/universedeb3.1.3+debian-12017-11-10822 kiB3.48 MiB

Latest updates

Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 3.1.4+debian-2+deb9u1 removed

Jan 12
Debian 9.0 icon

Debian 9.0 stretch/main: Updated from 3.1.4+debian-2 to 3.1.4+debian-2+deb9u1

Jan 12
  • Fix CVE-2017-12627: Alberto Garcia, Francisco Oca and Suleman Ali of Offensive Research discovered that the Xerces-C XML parser mishandles certain kinds of external DTD references, resulting in dereference of a NULL pointer while processing the path to the DTD. The bug allows for a denial of service attack in applications that allow DTD processing and do not prevent external DTD usage, and could conceivably result in remote code execution.
  • Fix a regression that forced gcc to use SSE2, even on platforms that do not support it (e.g., i386). This caused program crashes due to invalid CPU instructions.
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 3.1.4+debian-2+deb9u1 introduced

2018-06-19
  • Fix CVE-2017-12627: Alberto Garcia, Francisco Oca and Suleman Ali of Offensive Research discovered that the Xerces-C XML parser mishandles certain kinds of external DTD references, resulting in dereference of a NULL pointer while processing the path to the DTD. The bug allows for a denial of service attack in applications that allow DTD processing and do not prevent external DTD usage, and could conceivably result in remote code execution.
  • Fix a regression that forced gcc to use SSE2, even on platforms that do not support it (e.g., i386). This caused program crashes due to invalid CPU instructions.
Debian 10.0 icon

Debian 10.0 buster/main: Version 3.1.4+debian-2 removed

2017-12-07
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Version 3.1.4+debian-2build1 removed

2017-11-22
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 3.1.4+debian-2build2 removed

2017-11-16
Debian 10.0 icon

Debian 10.0 buster/main: Version 3.1.4+debian-2 introduced

2017-11-10
  • Fix AC_LANG_SOURCE warnings.
  • Override dh_auto_clean to also clean generated doc directory. Closes: 847799
  • Fix segfault in PSVIWriter. Closes: 715592
  • Use -O1 on s390x to work around Bug: 833754
  • Add hardening=+all build option
  • Remove lintian override that was no longer needed
Debian 9.0 icon

Debian 9.0 stretch/main: Version 3.1.4+debian-2 introduced

2017-11-10
  • Fix AC_LANG_SOURCE warnings.
  • Override dh_auto_clean to also clean generated doc directory. Closes: 847799
  • Fix segfault in PSVIWriter. Closes: 715592
  • Use -O1 on s390x to work around Bug: 833754
  • Add hardening=+all build option
  • Remove lintian override that was no longer needed
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 3.1.4+debian-2build2 introduced

2017-11-10
  • No-change rebuild for icu soname change.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Version 3.1.4+debian-2build1 introduced

2017-11-10
  • No-change rebuild for libicu soname change.
Ubuntu 17.10 icon

Ubuntu 17.10 artful/universe: Version 3.1.4+debian-2 introduced

2017-11-10
  • Fix AC_LANG_SOURCE warnings.
  • Override dh_auto_clean to also clean generated doc directory. Closes: 847799
  • Fix segfault in PSVIWriter. Closes: 715592
  • Use -O1 on s390x to work around Bug: 833754
  • Add hardening=+all build option
  • Remove lintian override that was no longer needed
Ubuntu 16.04 LTS icon

Ubuntu 16.04 LTS xenial/universe: Version 3.1.3+debian-1 introduced

2017-11-10
  • New upstream version.
    Fixes CVE-2016-0729: Apache Xerces-C XML Parser Crashes on Malformed Input. Closes: #815907
  • Add build dependency on libatk-wrapper-java. Closes: #816021
  • Updated standards version to 3.9.7 (no updates needed)
  • Lintian fixes

    d/copyright

    fix typo in filename
    fix duplicate license short name
    add .svn to excluded files

⇧ Top