Linux repositories inspector

libzookeeper-java - Core Java libraries for zookeeper

ZooKeeper is a centralized, reliable, service for maintaining configuration information, naming, providing distributed synchronization, and group services. All of these kinds of services are used in some form or another by distributed applications.
This package contains the java .jar files.
3.4.13
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
Ubuntu iconUbuntu 19.10
3.4.12
Ubuntu iconUbuntu 18.10
3.4.10
Ubuntu iconUbuntu 17.10
Ubuntu iconUbuntu 18.04 LTS
3.4.9
Debian iconDebian 9.0
3.4.8
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb3.4.13-2Jun 171.32 MiB1.46 MiB
Debian iconDebian 9.0 stretch/maindeb3.4.9-3+deb9u1Jan 121.3 MiB1.44 MiB
Debian iconDebian 9.0 stretch-proposed-updates/maindeb3.4.9-3+deb9u2Jun 181.3 MiB1.44 MiB
Ubuntu iconUbuntu 17.10 artful/universedeb3.4.10-22017-11-101.3 MiB1.44 MiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb3.4.10-32018-02-041.3 MiB1.44 MiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb3.4.12-2Jan 141.3 MiB1.44 MiB
Ubuntu iconUbuntu 19.04 disco/universedeb3.4.13-1Jan 141.32 MiB1.46 MiB
Ubuntu iconUbuntu 19.10 eoan/universedeb3.4.13-1Jun 171.32 MiB1.46 MiB
Ubuntu iconUbuntu 19.10 eoan-proposed/universedeb3.4.13-2Jun 171.32 MiB1.46 MiB
Ubuntu iconUbuntu 16.04 LTS xenial/universedeb3.4.8-12017-11-101.21 MiB1.35 MiB

Latest updates

Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 3.4.13-1 reintroduced

0 - 12:13
  • New upstream version 3.4.13
  • Update version in debian-provided pom file
  • Bump Standards-Version to 4.2.1
Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 3.4.13-1 removed

0 - 10:48
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 3.4.9-3+deb9u2 introduced

Jun 18
Ubuntu 19.10 icon

Ubuntu 19.10 eoan-proposed/universe: Version 3.4.13-2 introduced

Jun 17
Ubuntu 19.10 icon

Ubuntu 19.10 eoan/universe: Version 3.4.13-1 introduced

Jun 17
  • New upstream version 3.4.13
  • Update version in debian-provided pom file
  • Bump Standards-Version to 4.2.1
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 3.4.13-1 to 3.4.13-2

Jun 17
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Version 3.4.13-1 introduced

Jan 14
  • New upstream version 3.4.13
  • Update version in debian-provided pom file
  • Bump Standards-Version to 4.2.1
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic/universe: Version 3.4.12-2 introduced

Jan 14
  • Team upload.
tony mancill
  • Add patch for FTBFS with GCC-8 (Closes: #897892)
Markus Koschany
  • Declare compliance with Debian Policy 4.2.0.
  • debian/control: Remove ancient X-Python-Version field because it is satisfied even in oldstable.
  • Add 15-javadoc-doclet.patch. The missing doclet class causes a javadoc error. Now the documentation is built again.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 3.4.10-3 to 3.4.13-1

Jan 12
  • New upstream version 3.4.13
  • Update version in debian-provided pom file
  • Bump Standards-Version to 4.2.1
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 3.4.9-3+deb9u1 removed

Jan 12
Debian 9.0 icon

Debian 9.0 stretch/main: Updated from 3.4.9-3 to 3.4.9-3+deb9u1

Jan 12
  • Team upload.
  • Fix CVE-2018-8012:
    No authentication/authorization is enforced when a server attempts to join a quorum in Apache ZooKeeper. As a result an arbitrary end point could join the cluster and begin propagating counterfeit changes to the leader. (Closes: #899332)
Debian 9.0 icon

Debian 9.0 stretch-proposed-updates/main: Version 3.4.9-3+deb9u1 introduced

2018-06-19
  • Team upload.
  • Fix CVE-2018-8012:
    No authentication/authorization is enforced when a server attempts to join a quorum in Apache ZooKeeper. As a result an arbitrary end point could join the cluster and begin propagating counterfeit changes to the leader. (Closes: #899332)
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 3.4.10-2 to 3.4.10-3

2018-02-08
  • The default value of JMXLOCALONLY is now true (Closes: #869912)
  • Drop transitional package libzookeeper2 (Closes: #878994)
  • /var/lib/zookeeper is no longer world-readable (Closes: #870271)
  • Use debhelper 11 and set compat level to 11
  • Bump Standards-Version to 4.1.3
  • Use https for Homepage URL
  • Drop build-dep on dh-systemd in favor of debhelper 10
  • Remove init.d skeleton template boilerplate
  • Remove Upstart config
  • Add ./NOTICE.txt to debian/zookeeper.docs
  • Set build target to Java 8
  • Correct ivy profile during test phase on i386 (See: #860650) Note that this does not mean that tests pass on i386 now, only that the tests can be run without ivy dying.
  • Disable tests that use the MiniKdc class
  • Rename zooinspector JAR file to zookeeper-zooinspector as per policy
  • Add debian/NEWS
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 3.4.10-3 removed

2018-02-04
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 3.4.10-2 to 3.4.10-3

2018-02-04
  • The default value of JMXLOCALONLY is now true (Closes: #869912)
  • Drop transitional package libzookeeper2 (Closes: #878994)
  • /var/lib/zookeeper is no longer world-readable (Closes: #870271)
  • Use debhelper 11 and set compat level to 11
  • Bump Standards-Version to 4.1.3
  • Use https for Homepage URL
  • Drop build-dep on dh-systemd in favor of debhelper 10
  • Remove init.d skeleton template boilerplate
  • Remove Upstart config
  • Add ./NOTICE.txt to debian/zookeeper.docs
  • Set build target to Java 8
  • Correct ivy profile during test phase on i386 (See: #860650) Note that this does not mean that tests pass on i386 now, only that the tests can be run without ivy dying.
  • Disable tests that use the MiniKdc class
  • Rename zooinspector JAR file to zookeeper-zooinspector as per policy
  • Add debian/NEWS
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic-proposed/universe: Version 3.4.10-3 introduced

2018-02-04
  • The default value of JMXLOCALONLY is now true (Closes: #869912)
  • Drop transitional package libzookeeper2 (Closes: #878994)
  • /var/lib/zookeeper is no longer world-readable (Closes: #870271)
  • Use debhelper 11 and set compat level to 11
  • Bump Standards-Version to 4.1.3
  • Use https for Homepage URL
  • Drop build-dep on dh-systemd in favor of debhelper 10
  • Remove init.d skeleton template boilerplate
  • Remove Upstart config
  • Add ./NOTICE.txt to debian/zookeeper.docs
  • Set build target to Java 8
  • Correct ivy profile during test phase on i386 (See: #860650) Note that this does not mean that tests pass on i386 now, only that the tests can be run without ivy dying.
  • Disable tests that use the MiniKdc class
  • Rename zooinspector JAR file to zookeeper-zooinspector as per policy
  • Add debian/NEWS
Debian 10.0 icon

Debian 10.0 buster/main: Version 3.4.10-2 introduced

2017-11-10
  • Upload to unstable for the buster release cycle.
Debian 9.0 icon

Debian 9.0 stretch/main: Version 3.4.9-3 introduced

2017-11-10
  • Team upload.
  • Apply patch for CVE-2017-5637 (Closes: #863811)
    "wchp" and "wchc" are now disabled by default.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Version 3.4.10-2 introduced

2017-11-10
  • Upload to unstable for the buster release cycle.
Ubuntu 17.10 icon

Ubuntu 17.10 artful/universe: Version 3.4.10-2 introduced

2017-11-10
  • Upload to unstable for the buster release cycle.

Related packages

libzookeeper-java-doc - API Documentation for zookeeper
⇧ Top