Linux repositories inspector

python3-lldb7 - Python bindings for liblldb

This package contains the Python bindings to clang (C language) frontend for LLVM.
7.0.1
OpenSUSE iconOpenSUSE Leap 15.1
OpenSUSE iconOpenSUSE Leap 15.2
OpenSUSE iconOpenSUSE Tumbleweed
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm7.0.1-lp151.1.132019-04-10128 kiB700 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 update/ossrpm7.0.1-lp151.2.6.1Nov 14129 kiB700 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 update/ossrpm7.0.1-lp151.2.3.1Jul 19129 kiB700 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.2 ossrpm7.0.1-lp152.4.16Mar 23129 kiB700 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm7.0.1-14.2Mar 11148 kiB675 kiBhttps://bugs.opensuse.org

Latest updates

OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 7.0.1-lp152.4.14 to 7.0.1-lp152.4.16

Mar 23
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 7.0.1-lp152.4.12 to 7.0.1-lp152.4.14

Mar 19
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-14.1 to 7.0.1-14.2

Mar 11
  • Add compiler-rt-sanitizer-ipc-perm.patch to fix glibc 2.31 build.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-13.6 to 7.0.1-14.1

Mar 04
  • Add compiler-rt-sanitizer-ipc-perm.patch to fix glibc 2.31 build.
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 7.0.1-lp152.4.10 to 7.0.1-lp152.4.12

Feb 19
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-13.5 to 7.0.1-13.6

Feb 09
  • (Build)Require only python3-base instead of full python3 package, the additional modules are not required. Helps shortening the build dependency chain.
  • Remove python3-* requires from lldb7 subpackage, and add it to the bindings/pretty-printer subpackage (python3-lldb7).
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 7.0.1-lp152.4.8 to 7.0.1-lp152.4.10

Feb 04
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-13.4 to 7.0.1-13.5

Jan 25
  • (Build)Require only python3-base instead of full python3 package, the additional modules are not required. Helps shortening the build dependency chain.
  • Remove python3-* requires from lldb7 subpackage, and add it to the bindings/pretty-printer subpackage (python3-lldb7).
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 7.0.1-lp152.4.7 to 7.0.1-lp152.4.8

Jan 17
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-13.3 to 7.0.1-13.4

Jan 08
  • (Build)Require only python3-base instead of full python3 package, the additional modules are not required. Helps shortening the build dependency chain.
  • Remove python3-* requires from lldb7 subpackage, and add it to the bindings/pretty-printer subpackage (python3-lldb7).
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Version 7.0.1-lp152.4.7 introduced

Jan 07
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-13.2 to 7.0.1-13.3

Nov 18
  • (Build)Require only python3-base instead of full python3 package, the additional modules are not required. Helps shortening the build dependency chain.
  • Remove python3-* requires from lldb7 subpackage, and add it to the bindings/pretty-printer subpackage (python3-lldb7).
OpenSUSE icon

OpenSUSE Leap 15.1 update/oss: Updated from 7.0.1-lp151.2.3.1 to 7.0.1-lp151.2.6.1

Nov 14
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-12.1 to 7.0.1-13.2

Oct 24
  • (Build)Require only python3-base instead of full python3 package, the additional modules are not required. Helps shortening the build dependency chain.
  • Remove python3-* requires from lldb7 subpackage, and add it to the bindings/pretty-printer subpackage (python3-lldb7).
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-11.1 to 7.0.1-12.1

Oct 18
  • Move diagtool from llvm to clang subpackage.
  • Make sure clang is installed after llvm to prevent breaking the clang link group due to this change.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-10.1 to 7.0.1-11.1

Sep 12
  • Use the documented LLVM_ENABLE_RTTI to enable RTTI instead of LLVM_REQUIRES_RTTI, which "is an internal flag that individual targets can use to force RTTI". (boo#1139584)
  • Drop obsolete llvm-build-tests-with-rtti.patch.
  • Remove unneccesary dependencies:
    • groff, bison and flex don't seem to be used.
    • jsoncpp is no longer used since r338461.
    • Don't recommend scan-{build,view} in clang (boo#1145444).
    • Devel packages are only required in other devel packages, when their headers are included in the installed headers.
  • Remove some duplicate BuildRequires.
  • Move libxml to the main package, since Clang also needs it.
  • Remove unused (since r268685) CMake flags LLVM_ENABLE_TIMESTAMPS.
  • Package gold linker plugin again.
  • Don't build libc++ and python3-clang anymore, because they come from llvm8 now (boo#1145735).
  • Don't recommend scan-build and scan-view in clang. (boo#1145444)
  • Add versions to Provides/Conflicts except for files.
  • Fix installation of opt-viewer files when python3-clang is no longer built.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-9.1 to 7.0.1-10.1

Sep 06
  • Fix aarch64 build broken by last commit
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-8.1 to 7.0.1-9.1

Aug 19
  • Drop aarch64-disable-memorytest.patch: no longer needed.
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 7.0.1-7.2 to 7.0.1-8.1

Aug 15
  • Allow use of Gold linker to be conditional.
OpenSUSE icon

OpenSUSE Leap 15.1 update/oss: Version 7.0.1-lp151.2.3.1 introduced

Jul 19
  • Add a clang-%{_sonum} symlink, which is referenced by
    /usr/lib64/cmake/clang/ClangTargets.cmake (boo#1138457)

Related packages

python3 - interactive high-level object-oriented language (default python3 version)
lldb7 - Software debugger built using LLVM libraries
python3-lldb7-debuginfo - Debug information for package python3-lldb7
⇧ Top