Linux repositories inspector

qtwebengine5-doc - Qt 5 webengine documentation

Qt is a cross-platform C++ application framework. Qt's primary feature is its rich set of widgets that provide standard GUI functionality.
This package contains the documentation for the Qt 5 webengine libraries.
5.14.1
Debian iconDebian experimental
5.12.5
Ubuntu iconUbuntu 20.04
5.12.4
Ubuntu iconUbuntu 19.10
5.12.2
Ubuntu iconUbuntu 19.04
5.11.3
Debian iconDebian 10.0
5.11.1
KDE Neon iconKDE Neon Dev stable
KDE Neon iconKDE Neon Dev unstable
KDE Neon iconKDE Neon User
Ubuntu iconUbuntu 18.10
5.11.0
KDE Neon iconKDE Neon User
5.9.5
Ubuntu iconUbuntu 18.04 LTS
5.9.1
Ubuntu iconUbuntu 17.10
5.7.1
Debian iconDebian 9.0
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb5.11.3+dfsg-2+deb10u1Feb 082.28 MiB3.36 MiB
Debian iconDebian experimental experimental/maindeb5.14.1+dfsg-3Mar 201.3 MiB1.78 MiB
Debian iconDebian 9.0 stretch/maindeb5.7.1+dfsg-6.12017-11-101.64 MiB2.53 MiB
KDE Neon iconKDE Neon Dev stable xenial/maindeb5.11.1+dfsg-0xneon+16.04+xenial+build642019-01-141.78 MiB2.46 MiB
KDE Neon iconKDE Neon Dev unstable xenial/maindeb5.11.1+dfsg-0xneon+16.04+xenial+build642019-01-141.78 MiB2.46 MiB
KDE Neon iconKDE Neon User xenial/maindeb5.11.1+dfsg-0xneon+16.04+xenial+build642019-01-141.78 MiB2.46 MiB
KDE Neon iconKDE Neon User xenial/maindeb5.11.1+dfsg-0neon+16.04+xenial+build632019-01-141.78 MiB2.46 MiB
KDE Neon iconKDE Neon User xenial/maindeb5.11.0+dfsg-0neon+16.04+xenial+build602019-01-141.78 MiB2.46 MiB
Ubuntu iconUbuntu 17.10 artful/universedeb5.9.1+dfsg-42017-11-102.19 MiB3.24 MiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb5.9.5+dfsg-0ubuntu22018-06-192.25 MiB3.33 MiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb5.11.1+dfsg-2ubuntu42019-01-141.77 MiB2.7 MiB
Ubuntu iconUbuntu 18.10 cosmic-updates/universedeb5.11.1+dfsg-2ubuntu4.12019-04-091.94 MiB3 MiB
Ubuntu iconUbuntu 19.04 disco/universedeb5.12.2+dfsg-2ubuntu12019-04-052.4 MiB3.5 MiB
Ubuntu iconUbuntu 19.10 eoan/universedeb5.12.4+dfsg-1ubuntu1Jul 132.46 MiB3.57 MiB
Ubuntu iconUbuntu 20.04 focal/universedeb5.12.5+dfsg-7build1Mar 242.45 MiB3.57 MiB

Latest updates

Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-7build1 removed

Mar 24
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 5.12.5+dfsg-7 to 5.12.5+dfsg-7build1

Mar 24
  • No-change rebuild for icu soname change.
Debian icon

Debian experimental experimental/main: Updated from 5.14.1+dfsg-2 to 5.14.1+dfsg-3

Mar 20
  • Disable v8 embedded builtins on mipsel, to fix OOM error.
  • Add -latomic to dependencies of base component on mipsel.
  • Update symbols files from buildds’ and the current build logs.
Debian icon

Debian experimental experimental/main: Updated from 5.14.1+dfsg-1 to 5.14.1+dfsg-2

Mar 18
  • Include asm/ptrace.h instead of asm/ptrace-abi.h on mipsel.
  • Disable dav1d support on mipsel.
  • Update symbols files from buildds’ logs.
Debian icon

Debian experimental experimental/main: Version 5.14.1+dfsg-1 introduced

Mar 09
  • New upstream release.
  • Remove/update some obsolete paths from Files-Excluded.
    • Also update touch_files in debian/rules in a similar way.
  • Drop patches:
    • CVE-2019-5870.patch (applied upstream)
    • CVE-2019-13720.patch (applied upstream)
    • icu-65.patch (applied upstream)
    • pulseaudio-13.patch (applied upstream)
    • restore-jstemplate.patch (no longer needed)
  • Also drop no-icudtl-dat.patch. Starting with commit 395e61ff2e51dc7c Qt WebEngine uses the common resources location for icudtl.dat file. That location should exist, and the warnings should be no longer printed, so no need to silence them.
  • Rebase and refresh other patches.
  • Bump Qt build-dependencies to 5.14.1.
  • Do not treat ninja 1.10 as too old.
  • Temporarily build with bundled ICU. Upstream now requires ICU 64, but libqt5core5a is built against ICU 63.
    • Install icudtl.dat in libqt5webenginecore5.
  • Pass QMAKE_PYTHON2=python2 to qmake.
  • Update symbols files from the current build log.
  • Bump ABI version to qtwebengine-abi-5-14-1.
  • Exclude more non-free files.
    • Exclude the whole devtools-node-modules directory, it does not seem to be used.
  • Update Lintian overrides files.
  • Remove no longer existing paths from debian/copyright.
  • Remove debian/missing-sources/marked-v0.3.6.tar.gz. Upstream now contains non-minified version (see QTBUG-69273).
  • Fix license-file-listed-in-debian-copyright Lintian warnings.
  • Bump Standards-Version to 4.5.0, no changes needed.
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-7build1 introduced

Mar 04
  • No-change rebuild for icu soname change.
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-7 removed

Feb 27
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 5.12.5+dfsg-6ubuntu2 to 5.12.5+dfsg-7

Feb 27
Dmitry Shachnev
  • Limit Ubuntu arm64 builds to -j2.
  • Update debian/libqt5webenginecore5.symbols (closes: #951905).
Gianfranco Costamagna
  • Depend on python2 instead of python, also tweak the patch to change the calls to python binary.
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Updated from 5.12.5+dfsg-6ubuntu3 to 5.12.5+dfsg-7

Feb 26
Dmitry Shachnev
  • Limit Ubuntu arm64 builds to -j2.
  • Update debian/libqt5webenginecore5.symbols (closes: #951905).
Gianfranco Costamagna
  • Depend on python2 instead of python, also tweak the patch to change the calls to python binary.
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-6ubuntu3 introduced

Feb 14
  • No-change rebuild for icu soname change.
Ubuntu icon

Ubuntu 20.04 focal/universe: Updated from 5.12.5+dfsg-3ubuntu1 to 5.12.5+dfsg-6ubuntu2

Feb 09
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-6ubuntu2 removed

Feb 09
Ubuntu icon

Ubuntu 20.04 focal-proposed/universe: Version 5.12.5+dfsg-6ubuntu2 introduced

Feb 09
Debian icon

Debian 10.0 buster-proposed-updates/main: Version 5.11.3+dfsg-2+deb10u1 removed

Feb 08
Debian icon

Debian 10.0 buster/main: Updated from 5.11.3+dfsg-2 to 5.11.3+dfsg-2+deb10u1

Feb 08
  • Fix PDF parsing by adding the missing non-const overrides for CPDF_Dictionary::GetDict() and CPDF_Reference::GetDict(). This also fixes QWebEnginePage::print() method (closes: #919504).
  • Use ui/webui/resources/js/jstemplate_compiled.js provided by upstream instead of an empty file (closes: #882805).
  • Backport upstream patch to disable executable stack (closes: #887875).
Debian icon

Debian 10.0 buster-proposed-updates/main: Version 5.11.3+dfsg-2+deb10u1 introduced

Jan 09
  • Fix PDF parsing by adding the missing non-const overrides for CPDF_Dictionary::GetDict() and CPDF_Reference::GetDict(). This also fixes QWebEnginePage::print() method (closes: #919504).
  • Use ui/webui/resources/js/jstemplate_compiled.js provided by upstream instead of an empty file (closes: #882805).
  • Backport upstream patch to disable executable stack (closes: #887875).
Ubuntu icon

Ubuntu 20.04 focal/universe: Version 5.12.5+dfsg-3ubuntu1 introduced

Jan 07
Debian icon

Debian experimental experimental/main: Version 5.12.5+dfsg-2 removed

Oct 25
Debian icon

Debian experimental experimental/main: Updated from 5.12.5+dfsg-1 to 5.12.5+dfsg-2

Oct 15
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 5.12.4+dfsg-1ubuntu1 reintroduced

Oct 10

Related packages

qtwebengine5-doc-html - Qt 5 webengine HTML documentation
⇧ Top