Linux repositories inspector

sagemath-common - Open Source Mathematical Software - architecture-independent files

SageMath is a free open-source mathematics software system licensed under the GPL. It builds on top of many existing open-source packages: NumPy, SciPy, matplotlib, Sympy, Maxima, GAP, FLINT, R and many more. Access their combined power through a common, Python-based language or directly via interfaces or wrappers.
Mission: Creating a viable free open source alternative to Magma, Maple, Mathematica and Matlab.
This package contains the architecture-independent files of SageMath.
8.6
Debian iconDebian 10.0
Ubuntu iconUbuntu 19.04
8.3
Ubuntu iconUbuntu 18.10
8.1
Ubuntu iconUbuntu 18.04 LTS
7.4
Debian iconDebian 9.0
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb8.6-611.03.201915.4 MiB191 MiB
Debian iconDebian 9.0 stretch/maindeb7.4-910.11.20178.19 MiB52.6 MiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb8.1-7ubuntu119.06.20188.64 MiB57.3 MiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb8.3-2ubuntu114.01.201915.1 MiB187 MiB
Ubuntu iconUbuntu 19.04 disco/universedeb8.6-614.03.201915.4 MiB191 MiB

Manual pages

sage(1)

sage - Open Source Mathematical Software

Latest updates

Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Updated from 8.6-5 to 8.6-6

14.03.2019 20:07
  • New patches:
    • u1-sphinx-1.8-doctest-transform.patch
    • d0-mathjax.patch
  • Update u0-version-sphinx-1.8.patch.
  • Create symlinks to system mathjax to fix math typesetting in documentation.
  • Remove (Build-)Depends:
    • python-flask
    • python-flask-autoindex
    • python-flask-babel
    • python-flask-oldsessions
    • python-flask-openid
    • python-flask-silk
  • Move packages from Depends to Recommends of sagemath (they all stay Build-Depends):
    • maxima-sage-doc
    • pari-doc
    • python-sagenb-export
    • r-cran-lattice
    • singular-doc
  • Fix 'sage --version'. (Closes: #923166)
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 8.6-6 removed

14.03.2019 19:40
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 8.6-6 introduced

14.03.2019 16:50
  • New patches:
    • u1-sphinx-1.8-doctest-transform.patch
    • d0-mathjax.patch
  • Update u0-version-sphinx-1.8.patch.
  • Create symlinks to system mathjax to fix math typesetting in documentation.
  • Remove (Build-)Depends:
    • python-flask
    • python-flask-autoindex
    • python-flask-babel
    • python-flask-oldsessions
    • python-flask-openid
    • python-flask-silk
  • Move packages from Depends to Recommends of sagemath (they all stay Build-Depends):
    • maxima-sage-doc
    • pari-doc
    • python-sagenb-export
    • r-cran-lattice
    • singular-doc
  • Fix 'sage --version'. (Closes: #923166)
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 8.6-5 to 8.6-6

11.03.2019 23:09
  • New patches:
    • u1-sphinx-1.8-doctest-transform.patch
    • d0-mathjax.patch
  • Update u0-version-sphinx-1.8.patch.
  • Create symlinks to system mathjax to fix math typesetting in documentation.
  • Remove (Build-)Depends:
    • python-flask
    • python-flask-autoindex
    • python-flask-babel
    • python-flask-oldsessions
    • python-flask-openid
    • python-flask-silk
  • Move packages from Depends to Recommends of sagemath (they all stay Build-Depends):
    • maxima-sage-doc
    • pari-doc
    • python-sagenb-export
    • r-cran-lattice
    • singular-doc
  • Fix 'sage --version'. (Closes: #923166)
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 8.6-5 removed

26.02.2019 09:25
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Version 8.6-5 introduced

26.02.2019 09:15
  • New patches:
    • d0-threejs-default-in-notebooks.patch
      Makes threejs the default 3D viewer in the Jupyter and sagenb notebooks.
    • u1-pkgconfig-extra-link-flags.patch (Closes: #919573)
  • Update u0-version-sphinx-1.8.patch.
  • Exclude all png's from dh_strip_nondeterminism.
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 8.6-5 introduced

21.02.2019 06:50
  • New patches:
    • d0-threejs-default-in-notebooks.patch
      Makes threejs the default 3D viewer in the Jupyter and sagenb notebooks.
    • u1-pkgconfig-extra-link-flags.patch (Closes: #919573)
  • Update u0-version-sphinx-1.8.patch.
  • Exclude all png's from dh_strip_nondeterminism.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 8.6-4 to 8.6-5

11.02.2019 22:33
  • New patches:
    • d0-threejs-default-in-notebooks.patch
      Makes threejs the default 3D viewer in the Jupyter and sagenb notebooks.
    • u1-pkgconfig-extra-link-flags.patch (Closes: #919573)
  • Update u0-version-sphinx-1.8.patch.
  • Exclude all png's from dh_strip_nondeterminism.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 8.6-3 to 8.6-4

06.02.2019 22:17
Ximin Luo
  • Add Rules-Requires-Root: no, avoid using fakeroot.
Tobias Hansen
  • Install a desktop file to start the Jupyter notebook.
  • New (Build-)Depends:
    • python-sphinx (>= 1.8) (Closes: #920989)
  • Remove (Build-)Depends:
    • gnutls-dev
    • libblas-dev
    • libgcrypt-dev
    • python3-dev
    • scons
    • f2c
    • octave
    • python-crypto
    • python-gd
    • python-gnutls
    • python-jsonschema
    • python-moinmoin
    • python-ply
    • python-tk
  • Adjust two trivial test fixes.
  • New patches:
    • u0-version-sphinx-1.8-dependency.patch #26949
    • u0-version-sphinx-1.8.patch #26451
  • Don't install sage-env-config. (Closes: #918990)
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 8.6-2 to 8.6-3

28.01.2019 22:22
Tobias Hansen
  • New (Build-)Depends:
    • gap-online-help
    • gap-atlasrep
    • gap-table-of-marks
    • libopenblas-dev (on supported architectures)
  • Remove (Build-)Depends:
    • libatlas-base-dev (on openblas supported architectures)
    • liblapack-dev
  • Allow up to 50 test failures.
  • Run tests with appropriate --optional flag.
E. Madison Bray
  • New patch: u2-libgap-symbol-loading.patch
Debian 10.0 icon

Debian 10.0 buster/main: Version 8.6-2 introduced

23.01.2019 16:22
  • New (Build-)Depends:
    • ecl (>= 16.1.3)
    • maxima-sage (>= 5.41.0+ds-3)
  • New patches:
    • u0-version-ecl-16.1.3.patch #22191
  • Don't run dh_strip_nondeterminism on sageicon.png to avoid error.
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Version 8.4-2ubuntu2 removed

17.01.2019 10:02
Debian experimental icon

Debian experimental experimental/main: Version 8.6~rc0-1 removed

16.01.2019 11:21
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Version 8.4-2ubuntu2 introduced

14.01.2019 13:12
  • Regenerate the control file.
Debian experimental icon

Debian experimental experimental/main: Version 8.6~rc0-1 introduced

14.01.2019 03:35
  • New upstream release.
  • New (Build-)Depends:
    • cython (>= 0.29.1)
    • lcalc (>= 1.23+dfsg-10)
    • libflint-arb-dev (>= 1:2.15)
    • python-cypari2 (>= 1.3.1)
  • Remove patches (applied upstream):
    • u0-gap-util.patch
    • u0-version-gap-4.10.patch #22626
    • u0-version-numpy-1.14.3.patch #25260
    • u0-gap-trac-26889.patch #26889
    • u0-gap-trac-26856.patch #26856
    • u1-fix-mkdirs-sage-kernel-spec.patch #26176
    • u2-version-r-3.5.1-incomplete.patch #26185
Ubuntu 18.10 icon

Ubuntu 18.10 cosmic/universe: Version 8.3-2ubuntu1 introduced

14.01.2019 03:14
  • Merge with Debian; remaining changes:
    • Use gdb instead of gdb-python2 as a build dependency.
Debian 10.0 icon

Debian 10.0 buster/main: Version 8.1-2 removed

12.01.2019 14:16
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Updated from 8.1-3ubuntu1 to 8.1-7ubuntu1

19.06.2018 07:48
  • Merge from Debian unstable. Remaining changes:
    • Use gdb instead of gdb-python2 as a build dependency.
Ubuntu 18.04 LTS icon

Ubuntu 18.04 LTS bionic/universe: Version 8.1-3ubuntu1 introduced

26.02.2018 04:20
  • Use gdb instead of gdb-python2 as a build dependency.
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 8.0-10 to 8.1-2

03.01.2018 22:17
  • Upload to unstable.

Related packages

sagemath - Open Source Mathematics Software, free alternative to Magma, Maple, Mathematica, and Matlab
⇧ Top