Linux repositories inspector

suse-module-tools - Configuration for module loading and SUSE-specific utilities for KMPs

This package contains helper scripts for KMP installation and uninstallation, as well as default configuration files for depmod and modprobe. These utilities are provided by kmod-compat or module-init-tools, whichever implementation you choose to install.
15.2.10
OpenSUSE iconOpenSUSE Leap 15.2
OpenSUSE iconOpenSUSE Tumbleweed
15.1.18
OpenSUSE iconOpenSUSE Leap 15.1
15.1.13
OpenSUSE iconOpenSUSE Leap 15.1
15.0.6
OpenSUSE iconOpenSUSE Leap 15.0
15.0.2
OpenSUSE iconOpenSUSE Leap 15.0
15.0.1
OpenSUSE iconOpenSUSE Leap 15.0
12.4
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 42.3
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm12.4-lp150.1.72019-01-1732.2 kiB59.3 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm15.0.6-lp150.2.10.12019-08-0139.8 kiB81.9 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm15.0.2-lp150.2.6.12019-01-1840.3 kiB80.3 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm15.0.1-lp150.2.3.12019-01-1842.1 kiB89.1 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm15.1.13-lp151.1.12019-04-0941.8 kiB82.5 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 update/ossrpm15.1.18-lp151.2.4.12019-12-0942.4 kiB79.7 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.2 ossrpm15.2.10-lp152.1.12020-02-1942.3 kiB79.5 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 ossrpm12.4-5.32019-01-1727.5 kiB59.5 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm15.2.10-1.12020-01-2941.6 kiB79 kiBhttps://bugs.opensuse.org

Latest updates

OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 15.2.8-lp152.1.1 to 15.2.10-lp152.1.1

2020-02-19
  • Update to version 15.2.10:
    • ppc64le: fix dependency of papr_scm
      (bsc#1142152, ltc#176292, FATE#327775).
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Updated from 15.2.7-lp152.1.1 to 15.2.8-lp152.1.1

2020-02-04
  • Update to version 15.2.8:
    • Add modprobe.conf.s390x (bsc#1132798)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.2.9-1.1 to 15.2.10-1.1

2020-01-29
  • Update to version 15.2.10:
    • ppc64le: fix dependency of papr_scm
      (bsc#1142152, ltc#176292, FATE#327775).
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.2.7-1.1 to 15.2.9-1.1

2020-01-20
  • Update to version 15.2.9:
    • 00-system.conf: move br_netfilter softdep to separate file (boo#1158817)
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Version 15.2.7-lp152.1.1 introduced

2020-01-07
  • Update to version 15.2.7:
    • spec file: avoid %{_libexecdir}
OpenSUSE icon

OpenSUSE Leap 15.1 update/oss: Version 15.1.18-lp151.2.4.1 introduced

2019-12-09
  • Update to version 15.1.18:
    • modprobe.conf: add dependency of papr_scm on libnvdimm
      (bsc#1142152, ltc#176292, FATE#327775).
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.2.5-1.1 to 15.2.7-1.1

2019-11-18
  • Update to version 15.2.7:
    • spec file: avoid %{_libexecdir}
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.2.4-1.1 to 15.2.5-1.1

2019-08-30
  • Update to version 15.2.5:
    • remove 'modhash' - moved to mokutil package (jsc#SLE-6094)
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Updated from 15.0.2-lp150.2.6.1 to 15.0.6-lp150.2.10.1

2019-08-01
  • Update to version 15.0.6:
    • softdep of bridge on br_netfilter (bsc#937216, bsc#1134819)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.2.3-1.1 to 15.2.4-1.1

2019-07-22
  • Update to version 15.2.4:
    • sg.conf: avoid file conflict with system-tuning-common-SUSE
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.1.13-2.3 to 15.2.3-1.1

2019-07-16
  • Update to version 15.2.3:
    • softdep of bridge on br_netfilter (bsc#937216, bsc#1134819)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.1.13-1.1 to 15.1.13-2.3

2019-06-17
  • Only ship RPM macros up to suse_version 1500: after that, the macros can be found in the rpm-config-SUSE package.
OpenSUSE icon

OpenSUSE Leap 15.1 oss: Updated from 15.1.11-lp151.1.1 to 15.1.13-lp151.1.1

2019-04-09
  • Update to version 15.1.13:
    • spec file: add conflicts for dracut < 44.2 (bsc#1127891)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.1.11-1.1 to 15.1.13-1.1

2019-03-27
  • Update to version 15.1.13:
    • spec file: add conflicts for dracut < 44.2 (bsc#1127891)
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 15.0.2-lp150.2.6.1 reintroduced

2019-03-23
  • Update to version 15.0.2 (git 9f2adc34):
  • Move "weak-modules" script to -legacy subpackage to avoid dependency on binutils (bsc#1116665, bsc#1119371)
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 15.0.1-lp150.2.3.1 reintroduced

2019-03-23
  • Update to version 15.0.1 (git 5c63319):
  • Use /etc/modules-load.d/sg.conf for sg driver autoloading
    (bsc#1036463)
    • added /etc/modules-load.d/sg.conf
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 15.0.2-lp150.2.6.1 removed

2019-03-22
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 15.0.1-lp150.2.3.1 removed

2019-03-22
OpenSUSE icon

OpenSUSE Leap 15.1 oss: Updated from 15.1.10-lp151.1.1 to 15.1.11-lp151.1.1

2019-02-26
  • Update to version 15.1.11 (git 54df192):
    • spec file: use more gentle wording in blacklist files
    • spec file: drop jffs2 and ubifs from blacklist
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 15.1.10-1.1 to 15.1.11-1.1

2019-02-26
  • Update to version 15.1.11 (git 54df192):
    • spec file: use more gentle wording in blacklist files
    • spec file: drop jffs2 and ubifs from blacklist

Related packages

suse-module-tools-legacy - Legacy "weak-modules" script for Code10
⇧ Top