Linux repositories inspector

tar-rmt - Remote tape drive control server by GNU

Provides remote access to files and devices for tar, cpio
and similar backup utilities
1.32
OpenSUSE iconOpenSUSE Tumbleweed
1.30
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 15.1
OpenSUSE iconOpenSUSE Leap 15.2
1.29
OpenSUSE iconOpenSUSE Leap 15.0
DistributionVersionSincePackageInstalledPackager
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm1.29-lp150.1.122019-01-1745.6 kiB61.4 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.30-lp150.7.12019-06-1747.2 kiB57.4 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.30-lp150.2.3.22019-01-1846 kiB57.4 kiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm1.30-lp151.1.32019-01-2346 kiB57.4 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.2 ossrpm1.30-lp152.3.42020-01-0739.2 kiB57.4 kiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm1.32-2.12020-02-1157.2 kiB61.4 kiBhttps://bugs.opensuse.org

Manual pages

gnurmt(1)

rmt - remote magnetic tape server

Latest updates

OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.32-1.2 to 1.32-2.1

2020-02-11
  • No longer recommend -lang: supplements are in use.
OpenSUSE icon

OpenSUSE Leap 15.2 oss: Version 1.30-lp152.3.4 introduced

2020-01-07
  • add tar-1.30-CVE-2018-20482.patch to fix a security issue where tar when "--sparse" option is used, mishandles file shrinkage during read access, which allows local users to cause a denial of service (infinite read loop in sparse_dump_region in sparse.c) by modifying a file that is supposed to be archived by a different user's process [bsc#1120610] [CVE-2018-20482]
  • add tar-1.30-CVE-2019-9923.patch to fix a security issue where pax_decode_header in sparse.c in tar had a NULL pointer dereference when parsing certain archives that have malformed extended headers [bsc#1130496] [CVE-2019-9923]
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.32-1.1 to 1.32-1.2

2019-07-16
  • update to version 1.32
    • Fix the use of --checkpoint without explicit --checkpoint-action
    • Fix extraction with the -U option
    • Fix iconv usage on BSD-based systems
    • Fix possible NULL dereference (savannah bug #55369)
      bsc#1130496 [CVE-2019-9923]
    • Improve the testsuite
  • remove tar-1.31-tests_dirrem.patch and
    tar-1.31-racy_compress_tests.patch that are no longer needed (applied usptream)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.31-1.1 to 1.32-1.1

2019-06-17
  • update to version 1.32
    • Fix the use of --checkpoint without explicit --checkpoint-action
    • Fix extraction with the -U option
    • Fix iconv usage on BSD-based systems
    • Fix possible NULL dereference (savannah bug #55369)
      bsc#1130496 [CVE-2019-9923]
    • Improve the testsuite
  • remove tar-1.31-tests_dirrem.patch and
    tar-1.31-racy_compress_tests.patch that are no longer needed (applied usptream)
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Updated from 1.30-lp150.2.3.2 to 1.30-lp150.7.1

2019-06-17
  • add tar-1.30-CVE-2018-20482.patch to fix a security issue where tar when "--sparse" option is used, mishandles file shrinkage during read access, which allows local users to cause a denial of service (infinite read loop in sparse_dump_region in sparse.c) by modifying a file that is supposed to be archived by a different user's process [bsc#1120610] [CVE-2018-20482]
  • add tar-1.30-CVE-2019-9923.patch to fix a security issue where pax_decode_header in sparse.c in tar had a NULL pointer dereference when parsing certain archives that have malformed extended headers [bsc#1130496] [CVE-2019-9923]
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.30-1.3 to 1.31-1.1

2019-03-29
  • Remove libattr-devel from buildrequires, tar no longer uses it but finds xattr functions in libc.
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 1.30-lp150.2.3.2 reintroduced

2019-03-23
  • add tar-1.30-tests_dirrem_race.patch to fix race in dirrem01 and dirrem02 tests that were passing/failing randomly because of that
  • run spec-cleaner
  • renumber patches
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 1.30-lp150.2.3.2 removed

2019-03-22
OpenSUSE icon

OpenSUSE Tumbleweed oss: Updated from 1.30-1.2 to 1.30-1.3

2019-02-03
  • add tar-1.30-tests_dirrem_race.patch to fix race in dirrem01 and dirrem02 tests that were passing/failing randomly because of that
  • run spec-cleaner
  • renumber patches
OpenSUSE icon

OpenSUSE Tumbleweed oss: Version 1.30-1.2 reintroduced

2019-01-23
  • add tar-1.30-tests_dirrem_race.patch to fix race in dirrem01 and dirrem02 tests that were passing/failing randomly because of that
  • run spec-cleaner
  • renumber patches
OpenSUSE icon

OpenSUSE Leap 15.1 oss: Version 1.30-lp151.1.3 introduced

2019-01-23
  • add tar-1.30-tests_dirrem_race.patch to fix race in dirrem01 and dirrem02 tests that were passing/failing randomly because of that
  • run spec-cleaner
  • renumber patches
OpenSUSE icon

OpenSUSE Leap 15.0 update/oss: Version 1.30-lp150.2.3.2 introduced

2019-01-18
  • add tar-1.30-tests_dirrem_race.patch to fix race in dirrem01 and dirrem02 tests that were passing/failing randomly because of that
  • run spec-cleaner
  • renumber patches
OpenSUSE icon

OpenSUSE Leap 15.0 oss: Version 1.29-lp150.1.12 introduced

2019-01-17
  • remove tar-1.26-remove_O_NONBLOCK.patch as this issue was fixed in tar 1.27 (commit 03858cf583ce299b836d8a848967ce290a6bf303)
OpenSUSE icon

OpenSUSE Tumbleweed oss: Version 1.30-1.2 removed

2019-01-17
OpenSUSE icon

OpenSUSE Tumbleweed oss: Version 1.30-1.2 introduced

2019-01-17
  • add tar-1.30-tests_dirrem_race.patch to fix race in dirrem01 and dirrem02 tests that were passing/failing randomly because of that
  • run spec-cleaner
  • renumber patches

Related packages

tar - Utility used to store, backup, and transport files
rmt - Provides certain programs with access to remote tape devices
tar-rmt-debuginfo - Debug information for package tar-rmt
⇧ Top