Linux repositories inspector

whichman - Fault tolerant search utilities: whichman, ftff, ftwhich

whichman uses a fault tolerant approximate matching algorithm to search for man-pages that match approximately the specified name. The fault tolerant matching is very useful in cases where you remember only roughly the name of a command.

Example: whichman netwhat
This finds netstat.8: /usr/share/man/man8/netstat.8

ftff searches the directory tree. This is a case in-sensitive and fault tolerant way of 'find . -name xxxx -print'.
ftwhich finds files which are in one of the directories in your PATH and uses a fault tolerant search algorithm.
2.4
Debian iconDebian 10.0
Debian iconDebian 9.0
Ubuntu iconUbuntu 17.10
Ubuntu iconUbuntu 18.04 LTS
Ubuntu iconUbuntu 18.10
Ubuntu iconUbuntu 19.04
Ubuntu iconUbuntu 19.10
Ubuntu iconUbuntu 20.04
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb2.4-92019-01-1219.1 kiB66 kiB
Debian iconDebian 9.0 stretch/maindeb2.4-8+b12017-11-1019.1 kiB66 kiB
Ubuntu iconUbuntu 17.10 artful/universedeb2.4-82017-11-1018.3 kiB88 kiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb2.4-8build12018-06-1918.7 kiB62 kiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb2.4-92019-01-1418.7 kiB62 kiB
Ubuntu iconUbuntu 19.04 disco/universedeb2.4-92019-01-1418.7 kiB62 kiB
Ubuntu iconUbuntu 19.10 eoan/universedeb2.4-92019-06-1718.7 kiB62 kiB
Ubuntu iconUbuntu 20.04 focal/universedeb2.4-92020-01-0718.7 kiB62 kiB
Ubuntu iconUbuntu 16.04 LTS xenial/universedeb2.4-82017-11-1018.3 kiB88 kiB

Manual pages

ftff(1)

ftff - fault tolerant file find utility

ftwhich(1)

ftwhich - fault tolerant search for a command name

whichman(1)

whichman - show the location of a man page using a fault tolerant approximate matching algorithm

Latest updates

Ubuntu icon

Ubuntu 20.04 focal/universe: Version 2.4-9 introduced

2020-01-07
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-10-10
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-10-10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-10-10
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-10-10
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-25
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-09-25
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-25
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-09-25
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-06
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-09-06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-06
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-09-06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-06
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-09-06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-06
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-09-06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-06
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 removed

2019-09-06
Ubuntu icon

Ubuntu 19.10 eoan/universe: Version 2.4-9 reintroduced

2019-09-05
  • Add 12-Fix-gcc8-warnings.patch to fix 'implicit-fallthrough' warnings.
  • Switch to debhelper v11.
  • Enable all hardening options.
  • Switch debian/copyright into DEP-5 format.
  • Update Vcs-* fields for salsa migration.
  • Standards-Version: 4.1.4.
⇧ Top