Linux repositories inspector

znc-perl - advanced modular IRC bouncer (Perl extension)

znc is an IRC proxy. It runs as a daemon and connects to IRC server, then allows you to connect from a workstation and work as the user that is logged in to the IRC server. After you disconnect, it maintains the connection to the server. It acts like any normal IRC server, so you can use any IRC client to connect to it.
Some of its features include support for multiple users, multiple clients, and multiple IRC servers; playback buffers to catch up with what happened while you were detached, SSL encryption, DCC proxying, and a plugin interface with many plugins supporting other features.
This package contains the znc Perl extension.
Original maintainer
Homepagehttps://wiki.znc.in/ZNC
1.7.2
Debian iconDebian 10.0
Debian iconDebian 9.0
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 42.3
OpenSUSE iconOpenSUSE Tumbleweed
Ubuntu iconUbuntu 19.04
1.7.1
OpenSUSE iconOpenSUSE Leap 15.0
OpenSUSE iconOpenSUSE Leap 15.1
OpenSUSE iconOpenSUSE Leap 42.3
Ubuntu iconUbuntu 18.10
1.7.0
OpenSUSE iconOpenSUSE Leap 15.0
1.6.6
OpenSUSE iconOpenSUSE Leap 15.0
Ubuntu iconUbuntu 18.04 LTS
1.6.5
Debian iconDebian 9.0
Ubuntu iconUbuntu 17.10
1.6.4
OpenSUSE iconOpenSUSE Leap 42.3
1.6.3
Ubuntu iconUbuntu 16.04 LTS
DistributionVersionSincePackageInstalledPackager
Debian iconDebian 10.0 buster/maindeb1.7.2-205.04.2019722 kiB3.71 MiB
Debian iconDebian 9.0 stretch/maindeb1.6.5-1+deb9u112.01.2019597 kiB3.02 MiB
Debian iconDebian 9.0 stretch-backports/maindeb1.7.2-2~bpo9+108.04.2019701 kiB3.69 MiB
OpenSUSE iconOpenSUSE Leap 15.0 ossrpm1.6.6-lp150.1.117.01.2019610 kiB3.07 MiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.7.2-lp150.25.105.04.2019760 kiB3.93 MiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.7.1-lp150.2.6.118.01.2019761 kiB3.93 MiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.0 update/ossrpm1.7.0-lp150.2.3.118.01.2019760 kiB3.93 MiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 15.1 ossrpm1.7.1-lp151.1.420.03.2019760 kiB3.93 MiBhttps://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 ossrpm1.6.4-19.417.01.2019616 kiB3.14 MiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm1.7.2-25.105.04.2019767 kiB3.96 MiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Leap 42.3 update/ossrpm1.7.1-20.3.121.01.2019765 kiB3.96 MiBhttp://bugs.opensuse.org
OpenSUSE iconOpenSUSE Tumbleweed ossrpm1.7.2-2.129.03.2019767 kiB3.99 MiBhttps://bugs.opensuse.org
Ubuntu iconUbuntu 17.10 artful/universedeb1.6.5-2build210.11.2017577 kiB3.06 MiB
Ubuntu iconUbuntu 18.04 LTS bionic/universedeb1.6.6-119.06.2018579 kiB3.07 MiB
Ubuntu iconUbuntu 18.04 LTS bionic-security/universedeb1.6.6-1ubuntu0.112.01.2019581 kiB3.07 MiB
Ubuntu iconUbuntu 18.04 LTS bionic-updates/universedeb1.6.6-1ubuntu0.112.01.2019581 kiB3.07 MiB
Ubuntu iconUbuntu 18.10 cosmic/universedeb1.7.1-214.01.2019691 kiB3.76 MiB
Ubuntu iconUbuntu 19.04 disco/universedeb1.7.2-201.04.2019688 kiB3.76 MiB
Ubuntu iconUbuntu 16.04 LTS xenial/universedeb1.6.3-110.11.2017574 kiB3.04 MiB
Ubuntu iconUbuntu 16.04 LTS xenial-security/universedeb1.6.3-1ubuntu0.112.01.2019573 kiB3.04 MiB
Ubuntu iconUbuntu 16.04 LTS xenial-updates/universedeb1.6.3-1ubuntu0.112.01.2019573 kiB3.04 MiB

Latest updates

Debian 9.0 icon

Debian 9.0 stretch-backports/main: Updated from 1.7.2-1~bpo9+1 to 1.7.2-2~bpo9+1

08.04.2019 17:09
  • Rebuild for stretch-backports.
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Updated from 1.7.1-lp150.2.6.1 to 1.7.2-lp150.25.1

05.04.2019 15:44
  • Fix boo#1130360 CVE-2019-9917
    • znc-CVE-2019-9917.patch
OpenSUSE Leap 42.3 icon

OpenSUSE Leap 42.3 update/oss: Updated from 1.7.1-20.3.1 to 1.7.2-25.1

05.04.2019 11:21
  • Fix boo#1130360 CVE-2019-9917
    • znc-CVE-2019-9917.patch
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 1.7.2-1 to 1.7.2-2

05.04.2019 05:21
  • Add upstream patch 01-CVE-2019-9917 to fix a crash on invalid encoding, which fixes CVE-2019-9917.
    Closes: #925285
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 1.7.2-2 removed

01.04.2019 22:20
Ubuntu 19.04 icon

Ubuntu 19.04 disco/universe: Updated from 1.7.2-1 to 1.7.2-2

01.04.2019 21:18
See package znc
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.7.2-1.2 to 1.7.2-2.1

29.03.2019 15:47
  • Fix boo#1130360 CVE-2019-9917
    • znc-CVE-2019-9917.patch
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 1.7.2-2 introduced

27.03.2019 17:40
See package znc
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.7.1-lp150.2.6.1 reintroduced

23.03.2019 17:37
  • Update to version 1.7.1:
    • Security critical fixes[edit]
      • CVE-2018-14055: non-admin user could gain admin privileges and shell access by injecting values into znc.conf.
      • CVE-2018-14056: path traversal in HTTP handler via ../ in a web skin name.
    • Core
      • Fix znc-buildmod to not hardcode the compiler used to build ZNC anymore in CMake build (#1536)
      • Fix language selector. Russian and German were both not selectable.
      • Fix build without SSL support (#1554)
      • Fix several broken strings
      • Stop spamming users about debug mode. This feature was added in 1.7.0, now reverted. (#1541)
    • New
      • Add partial Spanish, Indonesian, and Dutch translations
    • Modules
      • adminlog: Log the error message again (regression of 1.7.0) (#1557)
      • admindebug: New module, which allows admins to turn on/off --debug in runtime (#1556)
      • flooddetach: Fix description of commands (#1548)
      • modperl: Fix memory leak in NV handling
      • modperl: Fix functions which return VCString (#1543)
      • modpython: Fix functions which return VCString (#1543)
      • webadmin: Fix fancy CTCP replies editor for Firefox. It was showing the plain version even when JS is enabled
    • Internal
      • Deprecate one of the overloads of CMessage::GetParams(), rename it to CMessage::GetParamsColon()
      • Don't throw from destructor in the integration test
      • Fix a warning with integration test / gmake / znc-buildmod interaction.
    • Drop upstream patches:
      • znc-inject2.patch
      • znc-inject.patch
      • znc-traversal.patch
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.7.0-lp150.2.3.1 reintroduced

23.03.2019 17:37
  • Define systemd unitdir for cmake
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.7.1-lp150.2.6.1 removed

22.03.2019 04:30
OpenSUSE Leap 15.0 icon

OpenSUSE Leap 15.0 update/oss: Version 1.7.0-lp150.2.3.1 removed

22.03.2019 04:30
OpenSUSE Leap 15.1 icon

OpenSUSE Leap 15.1 oss: Updated from 1.7.1-lp151.1.3 to 1.7.1-lp151.1.4

20.03.2019 19:50
  • Update to version 1.7.1:
    • Security critical fixes[edit]
      • CVE-2018-14055: non-admin user could gain admin privileges and shell access by injecting values into znc.conf.
      • CVE-2018-14056: path traversal in HTTP handler via ../ in a web skin name.
    • Core
      • Fix znc-buildmod to not hardcode the compiler used to build ZNC anymore in CMake build (#1536)
      • Fix language selector. Russian and German were both not selectable.
      • Fix build without SSL support (#1554)
      • Fix several broken strings
      • Stop spamming users about debug mode. This feature was added in 1.7.0, now reverted. (#1541)
    • New
      • Add partial Spanish, Indonesian, and Dutch translations
    • Modules
      • adminlog: Log the error message again (regression of 1.7.0) (#1557)
      • admindebug: New module, which allows admins to turn on/off --debug in runtime (#1556)
      • flooddetach: Fix description of commands (#1548)
      • modperl: Fix memory leak in NV handling
      • modperl: Fix functions which return VCString (#1543)
      • modpython: Fix functions which return VCString (#1543)
      • webadmin: Fix fancy CTCP replies editor for Firefox. It was showing the plain version even when JS is enabled
    • Internal
      • Deprecate one of the overloads of CMessage::GetParams(), rename it to CMessage::GetParamsColon()
      • Don't throw from destructor in the integration test
      • Fix a warning with integration test / gmake / znc-buildmod interaction.
    • Drop upstream patches:
      • znc-inject2.patch
      • znc-inject.patch
      • znc-traversal.patch
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.7.2-1.1 to 1.7.2-1.2

15.03.2019 14:49
  • Update to version 1.7.2:
    • Fix compilation without deprecated APIs in OpenSSL (#1615)
    • Distinguish Channel CTCP Requests and Replies (#1624)
    • admindebug: Enforce need of TTY to turn on debug mode (#1580)
    • controlpanel: Add missing return to ListNetMods (#1589)
    • webadmin: Fix adding the last allowed network (#1584)
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.7.1-1.10 to 1.7.2-1.1

26.02.2019 07:18
  • Update to version 1.7.2:
    • Fix compilation without deprecated APIs in OpenSSL (#1615)
    • Distinguish Channel CTCP Requests and Replies (#1624)
    • admindebug: Enforce need of TTY to turn on debug mode (#1580)
    • controlpanel: Add missing return to ListNetMods (#1589)
    • webadmin: Fix adding the last allowed network (#1584)
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.7.1-1.9 to 1.7.1-1.10

15.02.2019 12:58
  • Update to version 1.7.1:
    • Security critical fixes[edit]
      • CVE-2018-14055: non-admin user could gain admin privileges and shell access by injecting values into znc.conf.
      • CVE-2018-14056: path traversal in HTTP handler via ../ in a web skin name.
    • Core
      • Fix znc-buildmod to not hardcode the compiler used to build ZNC anymore in CMake build (#1536)
      • Fix language selector. Russian and German were both not selectable.
      • Fix build without SSL support (#1554)
      • Fix several broken strings
      • Stop spamming users about debug mode. This feature was added in 1.7.0, now reverted. (#1541)
    • New
      • Add partial Spanish, Indonesian, and Dutch translations
    • Modules
      • adminlog: Log the error message again (regression of 1.7.0) (#1557)
      • admindebug: New module, which allows admins to turn on/off --debug in runtime (#1556)
      • flooddetach: Fix description of commands (#1548)
      • modperl: Fix memory leak in NV handling
      • modperl: Fix functions which return VCString (#1543)
      • modpython: Fix functions which return VCString (#1543)
      • webadmin: Fix fancy CTCP replies editor for Firefox. It was showing the plain version even when JS is enabled
    • Internal
      • Deprecate one of the overloads of CMessage::GetParams(), rename it to CMessage::GetParamsColon()
      • Don't throw from destructor in the integration test
      • Fix a warning with integration test / gmake / znc-buildmod interaction.
    • Drop upstream patches:
      • znc-inject2.patch
      • znc-inject.patch
      • znc-traversal.patch
Debian 9.0 icon

Debian 9.0 stretch-backports/main: Updated from 1.7.1-2~bpo9+1 to 1.7.2-1~bpo9+1

03.02.2019 22:10
  • Rebuild for stretch-backports.
OpenSUSE Tumbleweed icon

OpenSUSE Tumbleweed oss: Updated from 1.7.1-1.7 to 1.7.1-1.9

03.02.2019 10:27
  • Update to version 1.7.1:
    • Security critical fixes[edit]
      • CVE-2018-14055: non-admin user could gain admin privileges and shell access by injecting values into znc.conf.
      • CVE-2018-14056: path traversal in HTTP handler via ../ in a web skin name.
    • Core
      • Fix znc-buildmod to not hardcode the compiler used to build ZNC anymore in CMake build (#1536)
      • Fix language selector. Russian and German were both not selectable.
      • Fix build without SSL support (#1554)
      • Fix several broken strings
      • Stop spamming users about debug mode. This feature was added in 1.7.0, now reverted. (#1541)
    • New
      • Add partial Spanish, Indonesian, and Dutch translations
    • Modules
      • adminlog: Log the error message again (regression of 1.7.0) (#1557)
      • admindebug: New module, which allows admins to turn on/off --debug in runtime (#1556)
      • flooddetach: Fix description of commands (#1548)
      • modperl: Fix memory leak in NV handling
      • modperl: Fix functions which return VCString (#1543)
      • modpython: Fix functions which return VCString (#1543)
      • webadmin: Fix fancy CTCP replies editor for Firefox. It was showing the plain version even when JS is enabled
    • Internal
      • Deprecate one of the overloads of CMessage::GetParams(), rename it to CMessage::GetParamsColon()
      • Don't throw from destructor in the integration test
      • Fix a warning with integration test / gmake / znc-buildmod interaction.
    • Drop upstream patches:
      • znc-inject2.patch
      • znc-inject.patch
      • znc-traversal.patch
Debian 10.0 icon

Debian 10.0 buster/main: Updated from 1.7.1-2+b3 to 1.7.2-1

01.02.2019 22:08
  • New upstream release.
  • Bump Standards-Version to 4.3.0.
  • Remove useless dh_auto_build and dh_auto_install overriding. Closes: #914777
  • Bump debian/compat to level 12.
  • Switch to dh_missing.
  • Install admindebug module.
Ubuntu 19.04 icon

Ubuntu 19.04 disco-proposed/universe: Version 1.7.2-1 removed

29.01.2019 16:50

Related packages

znc - An IRC bouncer with modules & scripts support
perl - Larry Wall's Practical Extraction and Report Language
znc-perl-debuginfo - Debug information for package znc-perl
⇧ Top